summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-06-30 16:03:20 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-06-30 16:03:20 +0000
commitcc037dcfb6911673f670c390b608272e9da25699 (patch)
tree9273c2adf6612259130c35a689ba2f57c985c190 /media-sound/vdramgw/vdramgw-0.0.2.ebuild
parentversion bump (diff)
downloadgentoo-2-cc037dcfb6911673f670c390b608272e9da25699.tar.gz
gentoo-2-cc037dcfb6911673f670c390b608272e9da25699.tar.bz2
gentoo-2-cc037dcfb6911673f670c390b608272e9da25699.zip
gcc-4.7 compile fixed, bug 424101; eapi=4; fixed c++ includes; minor fixes in ebuild
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-sound/vdramgw/vdramgw-0.0.2.ebuild')
-rw-r--r--media-sound/vdramgw/vdramgw-0.0.2.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/media-sound/vdramgw/vdramgw-0.0.2.ebuild b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
index 16f7c4a83290..6a73df242dc0 100644
--- a/media-sound/vdramgw/vdramgw-0.0.2.ebuild
+++ b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/vdramgw-0.0.2.ebuild,v 1.5 2010/08/13 21:31:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/vdramgw-0.0.2.ebuild,v 1.6 2012/06/30 16:03:20 hd_brummy Exp $
+
+EAPI="4"
inherit eutils toolchain-funcs
@@ -16,18 +18,20 @@ KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND=""
-RDEPEND=""
+RDEPEND="${DEPEND}"
+RDEPEND="media-sound/amarok"
S="${WORKDIR}/${MY_P#vdr-}/${PN}"
-RDEPEND="media-sound/amarok"
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
# Respect CC,CXXFLAGS, LDFLAGS
sed -i -e "/^CXX /s:?=.*:= $(tc-getCXX):" \
-e "/^CXXFLAGS/s:?=.*:= ${CFLAGS}:" \
-e "s:\$(CXXFLAGS):& \$(LDFLAGS) :" "${S}"/Makefile
+
+ cd "${WORKDIR}/${MY_P#vdr-}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}/${P}_gcc-4.7.diff"
}
src_install() {