summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-25 10:38:00 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-25 10:38:00 +0000
commitfd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101 (patch)
tree4e7f14334f287473b1bec3ca6121b697f39e1c40 /media-sound/trommler
parentFixed bug #161926, thanks to Daniel Klaffenbach, Tom Dexter and Francisco Llo... (diff)
downloadgentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.tar.gz
gentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.tar.bz2
gentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.zip
Version bump to GTK+-2.0 version, install desktop entry, smp2wav script, use toolchain-funcs, and more.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/trommler')
-rw-r--r--media-sound/trommler/ChangeLog10
-rw-r--r--media-sound/trommler/files/digest-trommler-3.73
-rw-r--r--media-sound/trommler/trommler-3.7.ebuild41
3 files changed, 52 insertions, 2 deletions
diff --git a/media-sound/trommler/ChangeLog b/media-sound/trommler/ChangeLog
index 72dbca55dd91..478e05fffbfc 100644
--- a/media-sound/trommler/ChangeLog
+++ b/media-sound/trommler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/trommler
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/ChangeLog,v 1.12 2006/10/28 23:32:06 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/ChangeLog,v 1.13 2007/07/25 10:38:00 drac Exp $
+
+*trommler-3.7 (25 Jul 2007)
+
+ 25 Jul 2007; Samuli Suominen <drac@gentoo.org> +trommler-3.7.ebuild:
+ Version bump to GTK+-2.0 version, install desktop entry, smp2wav script, use
+ toolchain-funcs, and more.
28 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> trommler-3.3.ebuild:
Fix dependency over GTK+ (it needs gtk+1.2). Thanks to Patrick Lauer in bug
diff --git a/media-sound/trommler/files/digest-trommler-3.7 b/media-sound/trommler/files/digest-trommler-3.7
new file mode 100644
index 000000000000..ae05afb2fe4d
--- /dev/null
+++ b/media-sound/trommler/files/digest-trommler-3.7
@@ -0,0 +1,3 @@
+MD5 971cc21a590fcfb7d01d7fb30d39d813 trommler.3.7.tar.gz 839481
+RMD160 b8381a80472137242caa422cb35d6bf0f86bf4d9 trommler.3.7.tar.gz 839481
+SHA256 51c7dab4aaf02fccc40700ded5b9891893edc7efa8825c2cb7527fac4a6c08b7 trommler.3.7.tar.gz 839481
diff --git a/media-sound/trommler/trommler-3.7.ebuild b/media-sound/trommler/trommler-3.7.ebuild
new file mode 100644
index 000000000000..68fd54d2f069
--- /dev/null
+++ b/media-sound/trommler/trommler-3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/trommler-3.7.ebuild,v 1.1 2007/07/25 10:38:00 drac Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN/t/T}
+
+DESCRIPTION="GTK+ based drum machine."
+HOMEPAGE="http://muth.org/Robert/Trommler"
+SRC_URI="http://muth.org/Robert/${MY_PN}/${P/-/.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc sox"
+
+RDEPEND=">=x11-libs/gtk+-2
+ sox? ( media-sound/sox )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/${MY_PN}
+
+src_compile() {
+ emake export.h || die "emake export.h failed."
+ emake CFLAGS="${CFLAGS} $(pkg-config --cflags gtk+-2.0)" \
+ CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} wav2smp playsample
+ use sox && dobin smp2wav
+ insinto /usr/share/${PN}/Drums
+ doins Drums/*.smp
+ insinto /usr/share/${PN}/Songs
+ doins Songs/*.sng
+ dodoc CHANGES README
+ use doc && dohtml index.html style.css
+ make_desktop_entry ${PN} Trommler
+}