summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-06-30 20:46:17 +0000
committerJohannes Huber <johu@gentoo.org>2012-06-30 20:46:17 +0000
commit3bb724a27635a2e38e2bcd538618ef917828d8a9 (patch)
treec1586d313f102fb69d4e141fb4d338720df39f13 /media-sound/tomahawk
parentvdr-plugin-2.eclass (diff)
downloadgentoo-2-3bb724a27635a2e38e2bcd538618ef917828d8a9.tar.gz
gentoo-2-3bb724a27635a2e38e2bcd538618ef917828d8a9.tar.bz2
gentoo-2-3bb724a27635a2e38e2bcd538618ef917828d8a9.zip
Sync live ebuild with dev overlay. Updates dependencies and build options.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/ChangeLog6
-rw-r--r--media-sound/tomahawk/tomahawk-9999.ebuild32
2 files changed, 14 insertions, 24 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index 3bc03a5ea662..eeaabae3b90e 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.11 2012/04/11 09:13:44 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.12 2012/06/30 20:46:17 johu Exp $
+
+ 30 Jun 2012; Johannes Huber <johu@gentoo.org> tomahawk-9999.ebuild:
+ Sync live ebuild with dev overlay. Updates dependencies and build options.
*tomahawk-0.4.2 (11 Apr 2012)
@@ -60,4 +63,3 @@
+files/tomahawk-0.3.0-remove-quazip.patch, +tomahawk-9999.ebuild,
+metadata.xml:
New application, bug 379385. Thanks to eliasp, johu and jmbsvicetto...
-
diff --git a/media-sound/tomahawk/tomahawk-9999.ebuild b/media-sound/tomahawk/tomahawk-9999.ebuild
index 15670b1bd0ae..414703b98f95 100644
--- a/media-sound/tomahawk/tomahawk-9999.ebuild
+++ b/media-sound/tomahawk/tomahawk-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.6 2012/04/06 08:44:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.7 2012/06/30 20:46:17 johu Exp $
EAPI=4
@@ -22,28 +22,28 @@ HOMEPAGE="http://tomahawk-player.org/"
LICENSE="GPL-3 BSD"
SLOT="0"
-IUSE="debug fftw jabber libsamplerate +resolver twitter"
+IUSE="debug fftw jabber libsamplerate twitter"
DEPEND="
app-crypt/qca
>=dev-cpp/clucene-2.3.3.4
>=dev-libs/boost-1.41
- >=dev-libs/qjson-0.7.1
- >=media-libs/libechonest-1.1.10
+ >=dev-libs/libattica-0.4.0
+ dev-libs/qjson
+ dev-libs/quazip
+ >=media-libs/liblastfm-1.0.1
+ media-libs/libechonest
>=media-libs/phonon-4.5.0
media-libs/taglib
+ x11-libs/libX11
>=x11-libs/qt-core-${QT_MINIMAL}:4
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
>=x11-libs/qt-gui-${QT_MINIMAL}:4
>=x11-libs/qt-sql-${QT_MINIMAL}:4[sqlite]
>=x11-libs/qt-webkit-${QT_MINIMAL}:4
- >=x11-libs/qt-xmlpatterns-${QT_MINIMAL}:4
fftw? ( sci-libs/fftw:3.0 )
jabber? ( net-libs/jreen )
libsamplerate? ( media-libs/libsamplerate )
- resolver? (
- dev-libs/libattica
- >=dev-libs/quazip-0.4.3
- )
twitter? ( net-libs/qtweetlib )
"
RDEPEND="${DEPEND}
@@ -53,14 +53,11 @@ RDEPEND="${DEPEND}
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with jabber Jreen)
- $(cmake-utils_use_with resolver LibAttica)
- $(cmake-utils_use_with resolver QuaZip)
$(cmake-utils_use_with twitter QTweetLib)
- -DINTERNAL_JREEN=OFF
)
if [[ ${PV} != *9999* ]]; then
- mycmakeargs+=( -DBUILD_RELEASE=ON )
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
fi
cmake-utils_src_configure
@@ -73,12 +70,3 @@ src_compile() {
src_install() {
cmake-utils_src_install
}
-
-pkg_postinst() {
- if ! use resolver; then
- echo
- elog "Information on how to get more resolvers for ${PN}"
- elog "is available at ${HOMEPAGE}resolvers"
- echo
- fi
-}