summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-10-01 14:59:48 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-10-01 14:59:48 +0000
commit2db22ec2119cfa3f53c4c4be01070d213e4151d2 (patch)
tree4e5d4ac9ea1d169f4da40e89cc946451cda91af0 /media-sound/sound-juicer
parentVersion bump (diff)
downloadgentoo-2-2db22ec2119cfa3f53c4c4be01070d213e4151d2.tar.gz
gentoo-2-2db22ec2119cfa3f53c4c4be01070d213e4151d2.tar.bz2
gentoo-2-2db22ec2119cfa3f53c4c4be01070d213e4151d2.zip
Add gtk3 git snapshot of sound-juicer for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/sound-juicer')
-rw-r--r--media-sound/sound-juicer/ChangeLog8
-rw-r--r--media-sound/sound-juicer/sound-juicer-2.99.0_pre20111001.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/media-sound/sound-juicer/ChangeLog b/media-sound/sound-juicer/ChangeLog
index 10c61faaf152..6a04fc55719e 100644
--- a/media-sound/sound-juicer/ChangeLog
+++ b/media-sound/sound-juicer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/sound-juicer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.208 2011/08/30 07:15:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.209 2011/10/01 14:59:48 nirbheek Exp $
+
+*sound-juicer-2.99.0_pre20111001 (01 Oct 2011)
+
+ 01 Oct 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +sound-juicer-2.99.0_pre20111001.ebuild:
+ Add gtk3 git snapshot of sound-juicer for GNOME 3
30 Aug 2011; Gilles Dartiguelongue <eva@gentoo.org>
sound-juicer-2.32.0-r1.ebuild:
diff --git a/media-sound/sound-juicer/sound-juicer-2.99.0_pre20111001.ebuild b/media-sound/sound-juicer/sound-juicer-2.99.0_pre20111001.ebuild
new file mode 100644
index 000000000000..2106c714bea4
--- /dev/null
+++ b/media-sound/sound-juicer/sound-juicer-2.99.0_pre20111001.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/sound-juicer-2.99.0_pre20111001.ebuild,v 1.1 2011/10/01 14:59:48 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="CD ripper for GNOME"
+HOMEPAGE="http://www.burtonini.com/blog/computers/sound-juicer/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.90:3
+ media-libs/libcanberra[gtk3]
+ >=app-cdr/brasero-2.90
+ >=gnome-base/gconf-2:2
+ sys-apps/dbus
+ dev-libs/dbus-glib
+
+ >=media-libs/musicbrainz-3.0.2:3
+ media-libs/libgnome-media-profiles:3
+
+ >=media-libs/gstreamer-0.10.15:0.10
+ >=media-libs/gst-plugins-base-0.10:0.10"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[cdda,udev]
+ >=media-plugins/gst-plugins-gconf-0.10:0.10
+ >=media-plugins/gst-plugins-gio-0.10:0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10:0.10
+ >=media-plugins/gst-plugins-cdio-0.10:0.10 )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/scrollkeeper-0.3.5
+ app-text/gnome-doc-utils
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+pkg_setup() {
+ # GST_INSPECT needed to get around some sandboxing checks
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ GST_INSPECT=$(type -p true)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If ${PN} does not rip to some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+}