summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-09 20:29:00 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-09 20:29:00 +0000
commitcac1be7b5d5ac5c18144a9e65ff464ab6e371468 (patch)
treec8921783174c17f948d79a67622ec855f4ca1d82 /media-sound/snd
parentNow corrected. stable release. Closes #7626. (diff)
downloadgentoo-2-cac1be7b5d5ac5c18144a9e65ff464ab6e371468.tar.gz
gentoo-2-cac1be7b5d5ac5c18144a9e65ff464ab6e371468.tar.bz2
gentoo-2-cac1be7b5d5ac5c18144a9e65ff464ab6e371468.zip
Now corrected. stable release. Closes #7626.
Diffstat (limited to 'media-sound/snd')
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/Manifest4
-rw-r--r--media-sound/snd/files/digest-snd-6.71
-rw-r--r--media-sound/snd/snd-6.7.ebuild74
4 files changed, 83 insertions, 3 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 6a6aa7a31c77..c4cfbcceb816 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd-6
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.3 2003/02/12 07:33:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.4 2003/04/09 20:28:38 mholzer Exp $
+
+*snd-6.7 (09 Apr 2003)
+
+ 09 Apr 2003; Martin Holzer <mholzer@gentoo.org> Manifest, snd-6.7.ebuild:
+ Now corrected. stable release. Closes #7626.
*snd-6.ebuild (6 Aug 2002)
diff --git a/media-sound/snd/Manifest b/media-sound/snd/Manifest
index 779fc4876db1..32cc64a76fed 100644
--- a/media-sound/snd/Manifest
+++ b/media-sound/snd/Manifest
@@ -1,5 +1,5 @@
-MD5 d2e8e0f746f0d0ff1335015a207f4916 ChangeLog 693
+MD5 1aa0a32bf422e37b65bb8d3128e9b01e ChangeLog 842
MD5 4c1b640c42b9058a92ceb69d1f618b16 snd-6.ebuild 1691
-MD5 83fa92f3c98725a0e37650016c81c952 snd-6.7.ebuild 1664
+MD5 cb1d2dd290bf2d6d219e1a413b4319d0 snd-6.7.ebuild 1667
MD5 cfd80dce79511197bafc596a9125c832 files/digest-snd-6.7 60
MD5 1ea5507c2a0014db967c8490f9d2becf files/digest-snd-6 58
diff --git a/media-sound/snd/files/digest-snd-6.7 b/media-sound/snd/files/digest-snd-6.7
new file mode 100644
index 000000000000..4dab4e9b8286
--- /dev/null
+++ b/media-sound/snd/files/digest-snd-6.7
@@ -0,0 +1 @@
+MD5 bcecb78dd2c9e89558432ae4004a8525 snd-6.7.tar.gz 4641334
diff --git a/media-sound/snd/snd-6.7.ebuild b/media-sound/snd/snd-6.7.ebuild
new file mode 100644
index 000000000000..f09875d9fcb0
--- /dev/null
+++ b/media-sound/snd/snd-6.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-6.7.ebuild,v 1.1 2003/04/09 20:28:38 mholzer Exp $
+
+IUSE="esd motif guile X gtk ruby alsa"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Snd is a sound editor"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://snd.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ dev-libs/gsl
+ media-libs/ladspa-sdk
+ media-libs/audiofile
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+ )
+ guile? ( dev-util/guile )
+ motif? ( x11-libs/openmotif )
+ ruby? ( dev-lang/ruby )"
+
+
+src_compile() {
+ local myconf
+
+ use alsa \
+ && myconf="${myconf} --with-alsa" \
+ || myconf="${myconf} --without-alsa"
+
+ use esd \
+ && myconf="${myconf} --with-esd" \
+ || myconf="${myconf} --without-esd"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use guile \
+ && myconf="${myconf} --with-guile --with-run" \
+ || myconf="${myconf} --without-guile"
+
+ use ruby \
+ && myconf="${myconf} --with-ruby" \
+ || myconf="${myconf} --without-ruby"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+# Seems to cause problem I will look into it but for now we will just disable
+# use gl \
+# && myconf="${myconf} --with-just-gl" \
+# || myconf="${myconf} --without-gl"
+
+ econf --with-ladspa --with-float-samples \
+ --with-float-sample-width ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ dobin snd
+
+ dodoc COPYING HISTORY.Snd README.Snd TODO.Snd
+
+ cd contrib/tutorial
+ dohtml *
+}