summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-20 18:36:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-20 18:36:30 +0000
commit18b7fc4deccf01cf8eec2f5c15f5640af59ae323 (patch)
tree77df6a1de4af4d04a4de2271f3a80ba0fd7cadb7 /media-sound/shell-fm
parentVersion bump #274840 by Arfrever Frehtes Taifersar Arahesis. (diff)
downloadgentoo-2-18b7fc4deccf01cf8eec2f5c15f5640af59ae323.tar.gz
gentoo-2-18b7fc4deccf01cf8eec2f5c15f5640af59ae323.tar.bz2
gentoo-2-18b7fc4deccf01cf8eec2f5c15f5640af59ae323.zip
Remove my devspace from SRC_URI as an alternative source since it's in mirrors. Remove old.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/shell-fm-0.5.ebuild38
-rw-r--r--media-sound/shell-fm/shell-fm-0.6.ebuild9
2 files changed, 5 insertions, 42 deletions
diff --git a/media-sound/shell-fm/shell-fm-0.5.ebuild b/media-sound/shell-fm/shell-fm-0.5.ebuild
deleted file mode 100644
index 843e00f919f4..000000000000
--- a/media-sound/shell-fm/shell-fm-0.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.5.ebuild,v 1.2 2008/05/12 15:29:40 drac Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="A lightweight console based player for Last.FM radio streams."
-HOMEPAGE="http://nex.scrapping.cc/code/shell-fm"
-SRC_URI="http://nex.scrapping.cc/code/${PN}/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="media-libs/libmad
- media-libs/libao"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s:gcc:$(tc-getCC):" -e "s:-Os:${CFLAGS}:" \
- source/Makefile || die "sed failed."
-}
-
-src_compile() {
- tc-export CC
- emake -C source || die "emake failed."
-}
-
-src_install() {
- dobin source/${PN} || die "dobin failed."
- doman manual/${PN}.1
- exeinto /usr/share/${PN}/scripts
- doexe scripts/{*.sh,zcontrol} || die "doexe failed."
-}
diff --git a/media-sound/shell-fm/shell-fm-0.6.ebuild b/media-sound/shell-fm/shell-fm-0.6.ebuild
index e6dff7d419bf..f0d69b120d87 100644
--- a/media-sound/shell-fm/shell-fm-0.6.ebuild
+++ b/media-sound/shell-fm/shell-fm-0.6.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.6.ebuild,v 1.2 2009/05/09 14:40:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.6.ebuild,v 1.3 2009/06/20 18:36:30 ssuominen Exp $
EAPI=2
inherit toolchain-funcs
DESCRIPTION="A lightweight console based player for Last.FM radio streams"
HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+# I couldn't get constant tarball from github so I've tarballed this myself.
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -18,7 +18,8 @@ IUSE="ao"
RDEPEND="media-libs/libmad
ao? ( media-libs/libao )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ sys-apps/sed"
src_prepare() {
sed -i -e "s:-Os:${CFLAGS}:g" source/Makefile || die "sed failed"