summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-07 23:50:44 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-07 23:50:44 +0000
commitacf9155fb134dfae7b6c918b7716e72238512d50 (patch)
treeb474dfb0f0de2107e6443718dd44a5ccdf574191 /media-sound/sexypsf/files
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-acf9155fb134dfae7b6c918b7716e72238512d50.tar.gz
gentoo-2-acf9155fb134dfae7b6c918b7716e72238512d50.tar.bz2
gentoo-2-acf9155fb134dfae7b6c918b7716e72238512d50.zip
ChangeLog
Diffstat (limited to 'media-sound/sexypsf/files')
-rw-r--r--media-sound/sexypsf/files/digest-sexypsf-0.4.61
-rw-r--r--media-sound/sexypsf/files/sexypsf-0.4.6-gentoo.patch54
-rw-r--r--media-sound/sexypsf/files/sexypsf-0.4.6-xmms.patch12
3 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/sexypsf/files/digest-sexypsf-0.4.6 b/media-sound/sexypsf/files/digest-sexypsf-0.4.6
new file mode 100644
index 000000000000..51156680b9d0
--- /dev/null
+++ b/media-sound/sexypsf/files/digest-sexypsf-0.4.6
@@ -0,0 +1 @@
+MD5 83fd68258efc2f7d319d033a263e4183 sexypsf046.tar.gz 92289
diff --git a/media-sound/sexypsf/files/sexypsf-0.4.6-gentoo.patch b/media-sound/sexypsf/files/sexypsf-0.4.6-gentoo.patch
new file mode 100644
index 000000000000..3be76d5935b3
--- /dev/null
+++ b/media-sound/sexypsf/files/sexypsf-0.4.6-gentoo.patch
@@ -0,0 +1,54 @@
+diff -Naur sexypsf.orig/Linux/Makefile sexypsf/Linux/Makefile
+--- sexypsf.orig/Linux/Makefile 2004-09-01 22:18:44.000000000 -0700
++++ sexypsf/Linux/Makefile 2004-10-07 16:42:22.932199622 -0700
+@@ -8,8 +8,7 @@
+ RM = rm -f
+ STRIP = strip
+
+-OPTIMIZE = -O2 -fomit-frame-pointer -finline-functions -ffast-math
+-FLAGS = -g -D__LINUX__ -DPSS_STYLE=1
++FLAGS = -g -D__LINUX__ -DPSS_STYLE=1 -fPIC
+ #-DTIMEO
+ LIBS = -lz
+
+@@ -20,7 +19,7 @@
+
+ OBJS+= LnxMain.o
+
+-CFLAGS = -Wall -Winline ${OPTIMIZE} -I. -I.. ${FLAGS}
++CFLAGS = -Wall -Winline -I. -I.. ${FLAGS}
+ #CFLAGS+= $(shell pkg-config gtk+-2.0 --cflags)
+
+ sexypsf: ${OBJS}
+diff -Naur sexypsf.orig/xmms/Makefile sexypsf/xmms/Makefile
+--- sexypsf.orig/xmms/Makefile 2004-09-01 13:43:13.000000000 -0700
++++ sexypsf/xmms/Makefile 2004-10-07 16:43:08.155808251 -0700
+@@ -12,7 +12,6 @@
+ RM = rm -f
+ #LD = ld -shared
+ LIBS = -lz -shared $(shell gtk-config --libs)
+-OPTIMIZE = -O2 -finline-functions -ffast-math
+-FLAGS = -DPSS_STYLE=1 -DSPSFVERSION="\"${VERSION}\""
++FLAGS = -DPSS_STYLE=1 -DSPSFVERSION="\"${VERSION}\"" -fPIC
+
+ OBJS = ../PsxBios.o ../PsxCounters.o ../PsxDma.o \
+@@ -22,10 +21,6 @@
+
+ OBJS+= xmms.o
+
+-ifeq (${CPU}, ix86)
+- OPTIMIZE += -fomit-frame-pointer -mcpu=i686 -fno-exceptions
+-endif
+-
+ ifeq (${CPU}, ppc)
+ FLAGS+=-DMSB_FIRST
+ endif
+@@ -34,7 +29,7 @@
+ FLAGS+=-DMSB_FIRST
+ endif
+
+-CFLAGS = -Wall ${OPTIMIZE} -I. -I.. -I/usr/include/g++ ${FLAGS}
++CFLAGS = -Wall -I. -I.. -I/usr/include/g++ ${FLAGS}
+ CFLAGS+= $(shell gtk-config --cflags)
+
+ #ifdef LD
diff --git a/media-sound/sexypsf/files/sexypsf-0.4.6-xmms.patch b/media-sound/sexypsf/files/sexypsf-0.4.6-xmms.patch
new file mode 100644
index 000000000000..dbafadf01742
--- /dev/null
+++ b/media-sound/sexypsf/files/sexypsf-0.4.6-xmms.patch
@@ -0,0 +1,12 @@
+diff -Naur sexypsf.orig/xmms/xmms.c sexypsf/xmms/xmms.c
+--- sexypsf.orig/xmms/xmms.c 2004-09-01 22:36:11.000000000 -0700
++++ sexypsf/xmms/xmms.c 2004-10-07 16:47:33.549594720 -0700
+@@ -101,7 +101,7 @@
+ }
+
+ static pthread_t dethread;
+-void sexyd_update(char *Buffer, int count)
++void sexyd_update(unsigned char *Buffer, long count)
+ {
+ if(count)
+ sexy_ip.add_vis_pcm(sexy_ip.output->written_time(), FMT_S16_NE, 2, count/4, Buffer);