summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-28 15:05:29 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-28 15:05:29 +0000
commit99f4c188d52fb7f9008aa5b255ca55934448c3ed (patch)
tree4fc82b7c36763e1bbf34496bd6ad4940b3e2f1cd /media-sound/qjackctl
parentBump for #401761. init script fix for #389965 (diff)
downloadgentoo-2-99f4c188d52fb7f9008aa5b255ca55934448c3ed.tar.gz
gentoo-2-99f4c188d52fb7f9008aa5b255ca55934448c3ed.tar.bz2
gentoo-2-99f4c188d52fb7f9008aa5b255ca55934448c3ed.zip
Prune old versions using deprecated qt4.eclass.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog6
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.2.ebuild47
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.7.ebuild47
3 files changed, 5 insertions, 95 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 069d9c82508e..3af3a50452ed 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.73 2012/03/28 09:59:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.74 2012/03/28 15:05:29 pesa Exp $
+
+ 28 Mar 2012; Davide Pesavento <pesa@gentoo.org> -qjackctl-0.3.2.ebuild,
+ -qjackctl-0.3.7.ebuild:
+ Prune old versions using deprecated qt4.eclass.
28 Mar 2012; Agostino Sarubbo <ago@gentoo.org> qjackctl-0.3.8.ebuild:
Stable for amd64, wrt bug #409705
diff --git a/media-sound/qjackctl/qjackctl-0.3.2.ebuild b/media-sound/qjackctl/qjackctl-0.3.2.ebuild
deleted file mode 100644
index fcd5f1d6c136..000000000000
--- a/media-sound/qjackctl/qjackctl-0.3.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.2.ebuild,v 1.13 2011/08/12 18:51:07 xarthisius Exp $
-
-EAPI=1
-
-inherit eutils qt4
-
-DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
-HOMEPAGE="http://qjackctl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-IUSE="alsa debug"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- >=media-sound/jack-audio-connection-kit-0.109.2"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- econf \
- $(use_enable alsa alsa-seq) \
- $(use_enable debug) \
- || die "econf failed"
-
- # Emulate what the Makefile does, so that we can get the correct
- # compiler used.
- eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
-
- emake -f ${PN}.mak || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- rm "${D}/usr/share/applications/qjackctl.desktop"
-
- # Upstream desktop file is invalid, better stick with our for now.
- make_desktop_entry "${PN}" "QjackCtl" "${PN}"
-
- dodoc README ChangeLog TODO AUTHORS
-}
diff --git a/media-sound/qjackctl/qjackctl-0.3.7.ebuild b/media-sound/qjackctl/qjackctl-0.3.7.ebuild
deleted file mode 100644
index b0033e7840dd..000000000000
--- a/media-sound/qjackctl/qjackctl-0.3.7.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.7.ebuild,v 1.4 2011/08/12 18:51:07 xarthisius Exp $
-
-EAPI=2
-
-inherit qt4
-
-DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
-HOMEPAGE="http://qjackctl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-IUSE="alsa dbus debug portaudio"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- dbus? ( x11-libs/qt-dbus )
- portaudio? ( media-libs/portaudio )
- >=media-sound/jack-audio-connection-kit-0.109.2"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- econf \
- $(use_enable alsa alsa-seq) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable portaudio)
-
- # Emulate what the Makefile does, so that we can get the correct
- # compiler used.
- eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
-}
-
-src_compile() {
- emake -f ${PN}.mak || die "emake failed"
- lupdate ${PN}.pro || die "lupdate failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README ChangeLog TODO AUTHORS TRANSLATORS
-}