summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-06 05:20:22 +0000
committerChris White <chriswhite@gentoo.org>2005-01-06 05:20:22 +0000
commit7b6b33a63f295de8dc564bfe3a3887ef3a84df6a (patch)
treec3624e85e756f122486817e34bca6f150dc7f0b3 /media-sound/potamus
parentBump, bug #76748 (Manifest recommit) (diff)
downloadgentoo-2-7b6b33a63f295de8dc564bfe3a3887ef3a84df6a.tar.gz
gentoo-2-7b6b33a63f295de8dc564bfe3a3887ef3a84df6a.tar.bz2
gentoo-2-7b6b33a63f295de8dc564bfe3a3887ef3a84df6a.zip
Initial import into the tree. Fixes bug #49149.
Diffstat (limited to 'media-sound/potamus')
-rw-r--r--media-sound/potamus/ChangeLog11
-rw-r--r--media-sound/potamus/Manifest2
-rw-r--r--media-sound/potamus/files/digest-potamus-200404141
-rw-r--r--media-sound/potamus/files/potamus-Makefile.patch25
-rw-r--r--media-sound/potamus/metadata.xml8
-rw-r--r--media-sound/potamus/potamus-20040414.ebuild42
6 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/potamus/ChangeLog b/media-sound/potamus/ChangeLog
new file mode 100644
index 000000000000..d419627b8288
--- /dev/null
+++ b/media-sound/potamus/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/potamus
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/ChangeLog,v 1.1 2005/01/06 05:20:22 chriswhite Exp $
+
+*potamus-20040414 (06 Jan 2005)
+
+ 06 Jan 2005; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/potamus-Makefile.patch, +potamus-20040414.ebuild:
+ Initial import to the tree. Fixes bug #49149. Thanks to Chris Davies for the
+ ebuild. Patch included to fix the Makefile.
+
diff --git a/media-sound/potamus/Manifest b/media-sound/potamus/Manifest
new file mode 100644
index 000000000000..407b5f5e4e6d
--- /dev/null
+++ b/media-sound/potamus/Manifest
@@ -0,0 +1,2 @@
+MD5 7e22d3891ddfa6224f70eaf7ae701e5c potamus-20040414.ebuild 846
+MD5 384c4c31d9fdeb5727b00cee662bb66f files/digest-potamus-20040414 72
diff --git a/media-sound/potamus/files/digest-potamus-20040414 b/media-sound/potamus/files/digest-potamus-20040414
new file mode 100644
index 000000000000..de65b8d0f693
--- /dev/null
+++ b/media-sound/potamus/files/digest-potamus-20040414
@@ -0,0 +1 @@
+MD5 f41246ad98db6de6eae94de8715b7df9 potamus-CVS-20040414.tar.bz2 11474
diff --git a/media-sound/potamus/files/potamus-Makefile.patch b/media-sound/potamus/files/potamus-Makefile.patch
new file mode 100644
index 000000000000..9e9e20efed98
--- /dev/null
+++ b/media-sound/potamus/files/potamus-Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile.old 2004-01-16 11:25:11.000000000 +0900
++++ Makefile 2005-01-06 14:03:06.640334056 +0900
+@@ -3,11 +3,11 @@
+ CPPFLAGS = -std=gnu99 -Wall -g `pkg-config --cflags $(PKGS)` -DDATADIR=\"$(datadir)\"
+ LIBS = `pkg-config --libs $(PKGS)`
+
+-prefix = /home/azz/src/potamus
++prefix = /usr
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ datadir = $(prefix)/share
+-DESTDIR =
++
+
+ potamus: $(OBJS)
+ $(CC) $(CPPFLAGS) -o potamus $(OBJS) $(LIBS)
+@@ -21,7 +21,7 @@
+ rm -f $(OBJS) potamus *~ *.bak depend share/potamus/*.bak
+
+ depend:
+- @for x in *.c ; do $(CXX) -MM $$x ; done >depend
++ @for x in *.c ; do $(CXX) `pkg-config --cflags $(PKGS)` -DDATADIR=\"$(datadir)\" -MM $$x ; done >depend
+ .PHONY: depend
+
+ include depend
diff --git a/media-sound/potamus/metadata.xml b/media-sound/potamus/metadata.xml
new file mode 100644
index 000000000000..1e8035259e42
--- /dev/null
+++ b/media-sound/potamus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>sound@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-sound/potamus/potamus-20040414.ebuild b/media-sound/potamus/potamus-20040414.ebuild
new file mode 100644
index 000000000000..869b73558e3f
--- /dev/null
+++ b/media-sound/potamus/potamus-20040414.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/potamus-20040414.ebuild,v 1.1 2005/01/06 05:20:22 chriswhite Exp $
+
+inherit eutils
+
+DESCRIPTION="Potamus, the GTK+ 2 sucessor to gnu xhippo"
+HOMEPAGE="http://offog.org/code/potamus.html"
+SRC_URI="http://offog.org/files/snapshots/potamus/${PN}-CVS-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE=""
+DEPEND=">=x11-libs/gtk+-2.0.0
+ >=gnome-base/libglade-2.0.0"
+RDEPEND="${DEPEND}
+ >=media-video/mplayer-0.92"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-Makefile.patch
+}
+
+src_compile() {
+
+ # We need to remove the azz specific bits from the makefile, so the
+ # resiyrces can be found OK
+
+ mv Makefile Makefile.old
+ sed -e 's/DESTDIR =//' -e 's/prefix = \/home\/azz\/src\/potamus/prefix = \/usr/' < Makefile.old > Makefile
+
+ emake DESTDIR=${D} || die "emake failed"
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}