summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-07-12 19:08:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-07-12 19:08:53 +0000
commitc4f0ef55f5fac2f0566a094b30f246f1eefba484 (patch)
treefe32019f6f46c517a93f02b076b1a3a9f9495596 /media-sound/nted
parentAdd patch for gcc-4.7. Bug #422665 (diff)
downloadgentoo-2-c4f0ef55f5fac2f0566a094b30f246f1eefba484.tar.gz
gentoo-2-c4f0ef55f5fac2f0566a094b30f246f1eefba484.tar.bz2
gentoo-2-c4f0ef55f5fac2f0566a094b30f246f1eefba484.zip
Add gcc-4.7 patch. Bug #424291
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog7
-rw-r--r--media-sound/nted/files/nted-1.10.18-gcc47.patch13
-rw-r--r--media-sound/nted/nted-1.10.18.ebuild9
3 files changed, 26 insertions, 3 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index 13506d0fbc94..dfa24a7e8bfd 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/nted
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.27 2012/05/21 06:33:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.28 2012/07/12 19:08:53 hwoarang Exp $
+
+ 12 Jul 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/nted-1.10.18-gcc47.patch, nted-1.10.18.ebuild:
+ Add gcc-4.7 patch. Bug #424291
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> nted-1.10.18.ebuild:
Remove || ( ) from LICENSE field because they are all required. Missing glib,
@@ -140,4 +144,3 @@
Vill
<gentoo@cconstruct.de> as proxy maintainer. Thanks to Dominik Kozaczko
<dominik@kozaczko.info> for the initial ebuild.
-
diff --git a/media-sound/nted/files/nted-1.10.18-gcc47.patch b/media-sound/nted/files/nted-1.10.18-gcc47.patch
new file mode 100644
index 000000000000..8e706f62b99b
--- /dev/null
+++ b/media-sound/nted/files/nted-1.10.18-gcc47.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=424291
+Index: nted-1.10.18/dynarray.h
+===================================================================
+--- nted-1.10.18.orig/dynarray.h
++++ nted-1.10.18/dynarray.h
+@@ -76,6 +76,7 @@ class NedDynArray {
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+
+ static void erroraus(const char *s) {
+ fprintf(stderr, "%s\n", s);
diff --git a/media-sound/nted/nted-1.10.18.ebuild b/media-sound/nted/nted-1.10.18.ebuild
index c49af193c6cd..9cccbcc9993a 100644
--- a/media-sound/nted/nted-1.10.18.ebuild
+++ b/media-sound/nted/nted-1.10.18.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18.ebuild,v 1.6 2012/05/21 06:33:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18.ebuild,v 1.7 2012/07/12 19:08:53 hwoarang Exp $
EAPI=4
+inherit eutils
+
DESCRIPTION="WYSIWYG score editor for GTK+"
HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
@@ -28,6 +30,11 @@ DEPEND="${RDEPEND}
DOCS="ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README"
+src_prepare() {
+ # bug #424291
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
src_configure() {
# Trick ./configure to believe we have gnome-extra/yelp installed.
has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"