summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-15 22:56:03 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-15 22:56:03 +0000
commit491cda45ec522e47fb594cc15184e23c5fedc40f (patch)
tree9c60feb343cb127e09bd426740cf3b386f37d3bd /media-sound/mpfc
parentVersion bump. Change init script to make it clear that it shuts down KVM/Qemu... (diff)
downloadgentoo-2-491cda45ec522e47fb594cc15184e23c5fedc40f.tar.gz
gentoo-2-491cda45ec522e47fb594cc15184e23c5fedc40f.tar.bz2
gentoo-2-491cda45ec522e47fb594cc15184e23c5fedc40f.zip
Revision bump. Update to EAPI 4 and add static-libs use flag.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpfc')
-rw-r--r--media-sound/mpfc/ChangeLog9
-rw-r--r--media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-sound/mpfc/ChangeLog b/media-sound/mpfc/ChangeLog
index fd0da3b5c441..14e4a3b660dc 100644
--- a/media-sound/mpfc/ChangeLog
+++ b/media-sound/mpfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpfc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.29 2011/06/08 09:56:05 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.30 2012/02/15 22:56:02 radhermit Exp $
+
+*mpfc-1.3.8.1-r1 (15 Feb 2012)
+
+ 15 Feb 2012; Tim Harder <radhermit@gentoo.org> +mpfc-1.3.8.1-r1.ebuild:
+ Revision bump. Update to EAPI 4 and add static-libs use flag.
08 Jun 2011; Diego E. Pettenò <flameeyes@gentoo.org> mpfc-1.3.8.1.ebuild:
QA: fix obvious typo.
diff --git a/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild b/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild
new file mode 100644
index 000000000000..b481f6e8a986
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild,v 1.1 2012/02/15 22:56:03 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="http://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cdda flac gpm mad nls oss static-libs vorbis wav"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ flac? ( media-libs/flac )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ sys-libs/ncurses[unicode]
+ dev-libs/icu"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable cdda audiocd) \
+ $(use_enable flac) \
+ $(use_enable gpm) \
+ $(use_enable mad mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable static-libs static) \
+ $(use_enable vorbis ogg) \
+ $(use_enable wav)
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mpfcrc
+
+ find "${D}" -name '*.la' -delete || die
+}