summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-10-31 21:49:48 +0000
committerChristoph Mende <angelos@gentoo.org>2009-10-31 21:49:48 +0000
commit16516917bd94c8701bcf5b4694b54ae377442206 (patch)
tree41031d375ad37bd927d810c7c3b1f0f494e5ad8b /media-sound/mpdscribble
parentRe-Keywording for ppc. (diff)
downloadgentoo-2-16516917bd94c8701bcf5b4694b54ae377442206.tar.gz
gentoo-2-16516917bd94c8701bcf5b4694b54ae377442206.tar.bz2
gentoo-2-16516917bd94c8701bcf5b4694b54ae377442206.zip
Version bump
(Portage version: 2.1.7.2/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/ChangeLog8
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.18.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index 4cd1cf31f8ff..2c0bf976a18f 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpdscribble
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.30 2009/08/17 20:35:18 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.31 2009/10/31 21:49:48 angelos Exp $
+
+*mpdscribble-0.18.1 (30 Oct 2009)
+
+ 30 Oct 2009; Christoph Mende <angelos@gentoo.org>
+ +mpdscribble-0.18.1.ebuild:
+ Version bump
17 Aug 2009; Christian Faulhammer <fauli@gentoo.org>
mpdscribble-0.17.ebuild:
diff --git a/media-sound/mpdscribble/mpdscribble-0.18.1.ebuild b/media-sound/mpdscribble/mpdscribble-0.18.1.ebuild
new file mode 100644
index 000000000000..c7b0c5b718e5
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.18.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.18.1.ebuild,v 1.1 2009/10/31 21:49:48 angelos Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ curl? ( net-misc/curl )
+ !curl? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myclient=soup
+ use curl && myclient=curl
+ econf \
+ --disable-dependency-tracking \
+ --with-http-client=${myclient}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ chmod 600 "${D}"/etc/mpdscribble.conf
+ dodoc AUTHORS NEWS README
+ rm -r -f "${D}"/usr/share/doc/${PN}
+ dodir /var/cache/mpdscribble
+}