summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-25 20:11:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-25 20:11:52 +0000
commit896e91dfc47e1e70cd3494fe5a0f470d157da00c (patch)
treeee961a566c8904b19db35fc4c2e6218635ad2f26 /media-sound/mhwaveedit
parentInitial commit. Fixes bug #362443. Required for grub2 as runtime dependency o... (diff)
downloadgentoo-2-896e91dfc47e1e70cd3494fe5a0f470d157da00c.tar.gz
gentoo-2-896e91dfc47e1e70cd3494fe5a0f470d157da00c.tar.bz2
gentoo-2-896e91dfc47e1e70cd3494fe5a0f470d157da00c.zip
version bump
(Portage version: 2.2.0_alpha35/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mhwaveedit')
-rw-r--r--media-sound/mhwaveedit/ChangeLog7
-rw-r--r--media-sound/mhwaveedit/mhwaveedit-1.4.21.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/mhwaveedit/ChangeLog b/media-sound/mhwaveedit/ChangeLog
index 180dc323aeed..73c170161692 100644
--- a/media-sound/mhwaveedit/ChangeLog
+++ b/media-sound/mhwaveedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mhwaveedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/ChangeLog,v 1.43 2011/01/06 23:50:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/ChangeLog,v 1.44 2011/05/25 20:11:52 aballier Exp $
+
+*mhwaveedit-1.4.21 (25 May 2011)
+
+ 25 May 2011; Alexis Ballier <aballier@gentoo.org> +mhwaveedit-1.4.21.ebuild:
+ version bump
*mhwaveedit-1.4.20 (06 Jan 2011)
diff --git a/media-sound/mhwaveedit/mhwaveedit-1.4.21.ebuild b/media-sound/mhwaveedit/mhwaveedit-1.4.21.ebuild
new file mode 100644
index 000000000000..191f64198a00
--- /dev/null
+++ b/media-sound/mhwaveedit/mhwaveedit-1.4.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/mhwaveedit-1.4.21.ebuild,v 1.1 2011/05/25 20:11:52 aballier Exp $
+
+EAPI=2
+
+DESCRIPTION="GTK+ Sound file editor (wav, and a few others.)"
+HOMEPAGE="https://gna.org/projects/mhwaveedit"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa esd jack ladspa libsamplerate nls oss pulseaudio sdl sndfile sox"
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ sndfile? ( >=media-libs/libsndfile-1.0.10 )
+ sdl? ( >=media-libs/libsdl-1.2.3 )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ esd? ( >=media-sound/esound-0.2 )
+ libsamplerate? ( media-libs/libsamplerate )
+ ladspa? ( media-libs/ladspa-sdk )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.10 )
+ sox? ( media-sound/sox )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --without-arts \
+ --without-portaudio \
+ $(use_enable nls) \
+ $(use_with sndfile libsndfile) \
+ $(use_with libsamplerate) \
+ $(use_with sdl) \
+ $(use_with alsa alsalib) \
+ $(use_with oss) \
+ $(use_with jack) \
+ $(use_with pulseaudio pulse) \
+ $(use_with esd esound)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README TODO
+}