summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2011-08-07 13:14:45 +0000
committerDaniel Pielmeier <billie@gentoo.org>2011-08-07 13:14:45 +0000
commit355f5703466d301dc01837532a8e62bdbe6307f5 (patch)
tree570b8b32b73b961a63ebe96e2b263d720b0e9188 /media-sound/mac
parentVersion bump. (diff)
downloadgentoo-2-355f5703466d301dc01837532a8e62bdbe6307f5.tar.gz
gentoo-2-355f5703466d301dc01837532a8e62bdbe6307f5.tar.bz2
gentoo-2-355f5703466d301dc01837532a8e62bdbe6307f5.zip
Switch to EAPI 4. Add static libs USE flag. Using --enable/disable-mmx is enough.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'media-sound/mac')
-rw-r--r--media-sound/mac/ChangeLog6
-rw-r--r--media-sound/mac/mac-3.99.4.5.7.ebuild26
2 files changed, 17 insertions, 15 deletions
diff --git a/media-sound/mac/ChangeLog b/media-sound/mac/ChangeLog
index 81b48052b8a1..88bfee4e39cd 100644
--- a/media-sound/mac/ChangeLog
+++ b/media-sound/mac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mac
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.21 2011/06/09 18:57:47 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.22 2011/08/07 13:14:45 billie Exp $
+
+ 07 Aug 2011; Daniel Pielmeier <billie@gentoo.org> mac-3.99.4.5.7.ebuild:
+ Switch to EAPI 4. Add static libs USE flag. Using --enable/disable-mmx is
+ enough.
09 Jun 2011; Daniel Pielmeier <billie@gentoo.org> -mac-3.99.4.5.6.ebuild:
Remove old.
diff --git a/media-sound/mac/mac-3.99.4.5.7.ebuild b/media-sound/mac/mac-3.99.4.5.7.ebuild
index 5c57563f7ba1..790eb4464af8 100644
--- a/media-sound/mac/mac-3.99.4.5.7.ebuild
+++ b/media-sound/mac/mac-3.99.4.5.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.7.ebuild,v 1.7 2011/03/06 12:10:26 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.7.ebuild,v 1.8 2011/08/07 13:14:45 billie Exp $
-EAPI=2
+EAPI=4
-inherit eutils flag-o-matic multilib versionator
+inherit flag-o-matic versionator
MY_PV=$(version_format_string '$1.$2-u$3-b$4')
PATCH=s$(get_version_component_range 5)
@@ -17,7 +17,7 @@ SRC_URI="http://etree.org/shnutils/shntool/support/formats/ape/unix/${MY_PV}-${P
LICENSE="mac"
SLOT="0"
KEYWORDS="alpha amd64 ppc x86"
-IUSE="mmx"
+IUSE="mmx static-libs"
RDEPEND=""
DEPEND="sys-apps/sed
@@ -37,18 +37,16 @@ pkg_setup() {
}
src_configure() {
- local mmx=no
- use mmx && mmx=yes
-
econf \
- --disable-dependency-tracking \
- --disable-static \
- --enable-assembly=${mmx}
+ $(use_enable static-libs static) \
+ $(use_enable mmx assembly)
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog* NEWS README TODO src/*.txt || die
- dohtml src/Readme.htm || die
- find "${D}"/usr/$(get_libdir) -name '*.la' -delete || die
+ default
+
+ dodoc ChangeLog.shntool src/*.txt
+ dohtml src/Readme.htm
+
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die
}