summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-12 10:36:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-12 10:36:16 +0000
commitb86adc0f474f177b06f0f96621efd37c18d3e4b9 (patch)
tree502f97c68fd7de7bf5a6e6275c4e678e492b66e3 /media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
parentand mention bug number in changelog (diff)
downloadgentoo-2-b86adc0f474f177b06f0f96621efd37c18d3e4b9.tar.gz
gentoo-2-b86adc0f474f177b06f0f96621efd37c18d3e4b9.tar.bz2
gentoo-2-b86adc0f474f177b06f0f96621efd37c18d3e4b9.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/linuxsampler/linuxsampler-0.5.1.ebuild')
-rw-r--r--media-sound/linuxsampler/linuxsampler-0.5.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
new file mode 100644
index 000000000000..c5d918171066
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild,v 1.1 2008/01/12 10:36:15 aballier Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features."
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack sqlite3"
+
+RDEPEND="sqlite3? ( >=dev-db/sqlite-3.3 )
+ >=media-libs/libgig-3.2.1
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-pkgconfiginit.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf --enable-alsa-driver \
+ $(use_enable jack jack-driver) \
+ $(use_enable sqlite3 instruments-db)
+ emake -j1 || die "emake failed."
+
+ if use doc; then
+ emake -j1 docs || die "emake docs failed."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}