summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-28 17:53:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-28 17:53:30 +0000
commitd4a32934c679dc80aa849d48a4312522105646f8 (patch)
tree47667092f915e12256a24d49d95a616668e96a01 /media-sound/lame
parentAdd missing dependencies wrt #392301 by Fabian Henze <flyser42@gmx.de>. Drop old (diff)
downloadgentoo-2-d4a32934c679dc80aa849d48a4312522105646f8.tar.gz
gentoo-2-d4a32934c679dc80aa849d48a4312522105646f8.tar.bz2
gentoo-2-d4a32934c679dc80aa849d48a4312522105646f8.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/lame-3.99.3.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 7584ae7c6855..595343b3fe97 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.135 2011/11/16 17:20:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.136 2011/11/28 17:53:29 ssuominen Exp $
+
+*lame-3.99.3 (28 Nov 2011)
+
+ 28 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> +lame-3.99.3.ebuild:
+ Version bump.
16 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> -lame-3.98.2-r1.ebuild,
-files/lame-3.98.2-ffmpeg-0.5.patch, -lame-3.99.ebuild:
diff --git a/media-sound/lame/lame-3.99.3.ebuild b/media-sound/lame/lame-3.99.3.ebuild
new file mode 100644
index 000000000000..0812b592f674
--- /dev/null
+++ b/media-sound/lame/lame-3.99.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.3.ebuild,v 1.1 2011/11/28 17:53:30 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug mmx mp3rtp sndfile static-libs"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.96-ccc.patch \
+ "${FILESDIR}"/${PN}-3.98-gtk-path.patch
+
+ mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm
+
+ sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
+
+ AT_M4DIR=${S} eautoreconf
+ epunt_cxx #74498
+}
+
+src_configure() {
+ local myconf
+ use sndfile && myconf="--with-fileio=sndfile"
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug norm) \
+ $(use_enable mmx nasm) \
+ --disable-mp3x \
+ $(use_enable mp3rtp) \
+ --enable-dynamic-frontends \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dobin misc/mlame
+
+ dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}