summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-16 17:20:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-16 17:20:05 +0000
commit8e01874f7fc21365150e7c472f327caf660b16cd (patch)
treebb3166c7140b6836ff51bdba9d1eb8aac490f5ce /media-sound/lame
parentVersion bump. (diff)
downloadgentoo-2-8e01874f7fc21365150e7c472f327caf660b16cd.tar.gz
gentoo-2-8e01874f7fc21365150e7c472f327caf660b16cd.tar.bz2
gentoo-2-8e01874f7fc21365150e7c472f327caf660b16cd.zip
old
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog6
-rw-r--r--media-sound/lame/files/lame-3.98.2-ffmpeg-0.5.patch86
-rw-r--r--media-sound/lame/lame-3.98.2-r1.ebuild87
-rw-r--r--media-sound/lame/lame-3.99.ebuild58
4 files changed, 5 insertions, 232 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 4ba9145adce0..7584ae7c6855 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.134 2011/11/16 17:18:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.135 2011/11/16 17:20:05 ssuominen Exp $
+
+ 16 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> -lame-3.98.2-r1.ebuild,
+ -files/lame-3.98.2-ffmpeg-0.5.patch, -lame-3.99.ebuild:
+ old
*lame-3.99.1 (16 Nov 2011)
diff --git a/media-sound/lame/files/lame-3.98.2-ffmpeg-0.5.patch b/media-sound/lame/files/lame-3.98.2-ffmpeg-0.5.patch
deleted file mode 100644
index 30528c7db95f..000000000000
--- a/media-sound/lame/files/lame-3.98.2-ffmpeg-0.5.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff -NrU5 lame-398-2.orig/libmp3lame/lame.c lame-398-2/libmp3lame/lame.c
---- lame-398-2.orig/libmp3lame/lame.c 2009-05-03 15:16:40.000000000 +0200
-+++ lame-398-2/libmp3lame/lame.c 2009-05-03 15:24:49.000000000 +0200
-@@ -1600,10 +1600,17 @@
- in_buffer[1] += n_in;
-
- /* update mfbuf[] counters */
- gfc->mf_size += n_out;
- assert(gfc->mf_size <= MFSIZE);
-+
-+ /* lame_encode_flush may have set gfc->mf_sample_to_encode to 0
-+ * so we have to reinitialize it here when that happened.
-+ */
-+ if (gfc->mf_samples_to_encode < 1) {
-+ gfc->mf_samples_to_encode = ENCDELAY + POSTDELAY;
-+ }
- gfc->mf_samples_to_encode += n_out;
-
-
- if (gfc->mf_size >= mf_needed) {
- /* encode the frame. */
-@@ -1929,10 +1936,14 @@
- int end_padding = POSTDELAY;
- int pad_out_samples;
- int frames_left;
- int samples_to_encode = gfc->mf_samples_to_encode;
-
-+ /* Was flush already called? */
-+ if (gfc->mf_samples_to_encode < 1) {
-+ return 0;
-+ }
- memset(buffer, 0, sizeof(buffer));
- mp3count = 0;
-
- if (gfp->in_samplerate != gfp->out_samplerate) {
- /* delay due to resampling; needs to be fixed, if resampling code gets changed */
-@@ -1940,35 +1951,38 @@
- }
- pad_out_samples = gfp->framesize - (samples_to_encode % gfp->framesize);
- end_padding += pad_out_samples;
-
- frames_left = (samples_to_encode + pad_out_samples) / gfp->framesize;
-- while (frames_left > 0) {
-+
-+ /* send in a frame of 0 padding until all internal sample buffers are flushed */
-+ while (frames_left > 0 && imp3 >= 0) {
- int frame_num = gfp->frameNum;
-
- mp3buffer_size_remaining = mp3buffer_size - mp3count;
-
- /* if user specifed buffer size = 0, dont check size */
- if (mp3buffer_size == 0)
- mp3buffer_size_remaining = 0;
-
-- /* send in a frame of 0 padding until all internal sample buffers
-- * are flushed
-- */
- imp3 = lame_encode_buffer(gfp, buffer[0], buffer[1], 32,
- mp3buffer, mp3buffer_size_remaining);
-
-- if (frame_num != gfp->frameNum) {
-- --frames_left;
-- }
-- if (imp3 < 0) {
-- /* some type of fatal error */
-- return imp3;
-- }
- mp3buffer += imp3;
- mp3count += imp3;
-+ frames_left -= (frame_num != gfp->frameNum) ? 1 : 0;
- }
-+ /* Set gfc->mf_samples_to_encode to 0, so we may detect
-+ * and break loops calling it more than once in a row.
-+ */
-+ gfc->mf_samples_to_encode = 0;
-+
-+ if (imp3 < 0) {
-+ /* some type of fatal error */
-+ return imp3;
-+ }
-+
- mp3buffer_size_remaining = mp3buffer_size - mp3count;
- /* if user specifed buffer size = 0, dont check size */
- if (mp3buffer_size == 0)
- mp3buffer_size_remaining = 0;
-
diff --git a/media-sound/lame/lame-3.98.2-r1.ebuild b/media-sound/lame/lame-3.98.2-r1.ebuild
deleted file mode 100644
index 75d726268bfc..000000000000
--- a/media-sound/lame/lame-3.98.2-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.98.2-r1.ebuild,v 1.9 2010/10/04 15:21:56 mr_bones_ Exp $
-
-inherit flag-o-matic toolchain-funcs eutils autotools versionator
-
-DESCRIPTION="LAME Ain't an MP3 Encoder"
-HOMEPAGE="http://lame.sourceforge.net"
-
-MY_PV=$(replace_version_separator 1 '')
-[ ${MY_PV/.} = ${MY_PV} ] || MY_PV=$(replace_version_separator 1 '-' ${MY_PV})
-S=${WORKDIR}/${PN}-${MY_PV}
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug mmx mp3rtp sndfile"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- sndfile? ( >=media-libs/libsndfile-1.0.2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- mmx? ( dev-lang/nasm )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # The frontened tries to link staticly, but we prefer shared libs
- epatch "${FILESDIR}"/${PN}-3.98-shared-frontend.patch
-
- # If ccc (alpha compiler) is installed on the system, the default
- # configure is broken, fix it to respect CC. This is only
- # directly broken for ARCH=alpha but would affect anybody with a
- # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
- epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
-
- # Patch gtk stuff, otherwise eautoreconf dies
- epatch "${FILESDIR}"/${PN}-3.98-gtk-path.patch
-
- # Fix for ffmpeg-0.5, bug 265830
- epatch "${FILESDIR}"/${PN}-3.98.2-ffmpeg-0.5.patch
-
- # It fails parallel make otherwise when enabling nasm...
- mkdir "${S}/libmp3lame/i386/.libs" || die
-
- sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
-
- AT_M4DIR="${S}" eautoreconf
- epunt_cxx # embedded bug #74498
-}
-
-src_compile() {
- use sndfile && myconf="--with-fileio=sndfile"
- # The user sets compiler optimizations... But if you'd like
- # lame to choose it's own... uncomment one of these (experiMENTAL)
- # myconf="${myconf} --enable-expopt=full \
- # myconf="${myconf} --enable-expopt=norm \
-
- econf \
- --enable-shared \
- $(use_enable debug debug norm) \
- --disable-mp3x \
- $(use_enable mmx nasm) \
- $(use_enable mp3rtp) \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
-
- dodoc API ChangeLog HACKING README* STYLEGUIDE TODO USAGE || die
- dohtml misc/lameGUI.html Dll/LameDLLInterface.htm || die
-
- dobin "${S}"/misc/mlame || die
-}
-
-pkg_postinst(){
- if use mp3rtp ; then
- ewarn "Warning, support for the encode-to-RTP program, 'mp3rtp'"
- ewarn "is broken as of August 2001."
- ewarn " "
- fi
-}
diff --git a/media-sound/lame/lame-3.99.ebuild b/media-sound/lame/lame-3.99.ebuild
deleted file mode 100644
index 988872ec7c39..000000000000
--- a/media-sound/lame/lame-3.99.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.ebuild,v 1.1 2011/10/21 21:56:10 ssuominen Exp $
-
-EAPI=4
-inherit autotools eutils
-
-DESCRIPTION="LAME Ain't an MP3 Encoder"
-HOMEPAGE="http://lame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug mmx mp3rtp sndfile static-libs"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- sndfile? ( >=media-libs/libsndfile-1.0.2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- mmx? ( dev-lang/nasm )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.96-ccc.patch \
- "${FILESDIR}"/${PN}-3.98-gtk-path.patch
-
- mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm
-
- sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
-
- AT_M4DIR=${S} eautoreconf
- epunt_cxx #74498
-}
-
-src_configure() {
- local myconf
- use sndfile && myconf="--with-fileio=sndfile"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug debug norm) \
- $(use_enable mmx nasm) \
- --disable-mp3x \
- $(use_enable mp3rtp) \
- --enable-dynamic-frontends \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
- dobin misc/mlame
-
- dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE
- dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}