summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-09-23 22:46:29 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-09-23 22:46:29 +0000
commit6357f3ca762c239b90726cf9e60597b3c2fd1534 (patch)
tree82c08ea2d3933365a524751885b98d95599d3f66 /media-sound/lame
parentInitial commit. Ebuild based on the one from upstream. (diff)
downloadgentoo-2-6357f3ca762c239b90726cf9e60597b3c2fd1534.tar.gz
gentoo-2-6357f3ca762c239b90726cf9e60597b3c2fd1534.tar.bz2
gentoo-2-6357f3ca762c239b90726cf9e60597b3c2fd1534.zip
Bump to 3.98.2, bug 238443. Drop a bunch of patches that were merged upstream.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog8
-rw-r--r--media-sound/lame/lame-3.98.2.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 41bd246e185e..dcd8ad030906 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.101 2008/08/08 08:29:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.102 2008/09/23 22:46:29 loki_val Exp $
+
+*lame-3.98.2 (23 Sep 2008)
+
+ 23 Sep 2008; Peter Alfredsen <loki_val@gentoo.org> +lame-3.98.2.ebuild:
+ Bump to 3.98.2, bug 238443. Drop a bunch of patches that were merged
+ upstream.
08 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+files/lame-3.98-echo.patch, lame-3.98.ebuild:
diff --git a/media-sound/lame/lame-3.98.2.ebuild b/media-sound/lame/lame-3.98.2.ebuild
new file mode 100644
index 000000000000..c70e14a1619b
--- /dev/null
+++ b/media-sound/lame/lame-3.98.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.98.2.ebuild,v 1.1 2008/09/23 22:46:29 loki_val Exp $
+
+inherit flag-o-matic toolchain-funcs eutils autotools versionator
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+
+MY_PV=$(replace_version_separator 1 '')
+[ ${MY_PV/.} = ${MY_PV} ] || MY_PV=$(replace_version_separator 1 '-' ${MY_PV})
+S=${WORKDIR}/${PN}-${MY_PV}
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug mmx mp3rtp sndfile"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # The frontened tries to link staticly, but we prefer shared libs
+ epatch "${FILESDIR}"/${PN}-3.98-shared-frontend.patch
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
+
+ # Patch gtk stuff, otherwise eautoreconf dies
+ epatch "${FILESDIR}"/${PN}-3.98-gtk-path.patch
+
+ # It fails parallel make otherwise when enabling nasm...
+ mkdir "${S}/libmp3lame/i386/.libs" || die
+
+ AT_M4DIR="${S}" eautoreconf
+ epunt_cxx # embedded bug #74498
+}
+
+src_compile() {
+ use sndfile && myconf="--with-fileio=sndfile"
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ $(use_enable debug debug norm) \
+ --disable-mp3x \
+ $(use_enable mmx nasm) \
+ $(use_enable mp3rtp) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING README* STYLEGUIDE TODO USAGE || die
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm || die
+
+ dobin "${S}"/misc/mlame || die
+}
+
+pkg_postinst(){
+ if use mp3rtp ; then
+ ewarn "Warning, support for the encode-to-RTP program, 'mp3rtp'"
+ ewarn "is broken as of August 2001."
+ ewarn " "
+ fi
+}