summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-28 16:32:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-28 16:32:17 +0000
commitcd029dc955124944d06a90bf2534d1310a6cb8a1 (patch)
treed78a9d82e45847c4a4ac6987703b61e1491d6127 /media-sound/jackbeat
parentStable for HPPA (bug #512492). (diff)
downloadgentoo-2-cd029dc955124944d06a90bf2534d1310a6cb8a1.tar.gz
gentoo-2-cd029dc955124944d06a90bf2534d1310a6cb8a1.tar.bz2
gentoo-2-cd029dc955124944d06a90bf2534d1310a6cb8a1.zip
Link against gmodule-2.0 libraries wrt #508988 by Gabriel Homeier and Ted Tanberry
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound/jackbeat')
-rw-r--r--media-sound/jackbeat/ChangeLog10
-rw-r--r--media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch17
-rw-r--r--media-sound/jackbeat/jackbeat-0.7.6.ebuild17
3 files changed, 33 insertions, 11 deletions
diff --git a/media-sound/jackbeat/ChangeLog b/media-sound/jackbeat/ChangeLog
index 8f21f813625f..8a745a4996c5 100644
--- a/media-sound/jackbeat/ChangeLog
+++ b/media-sound/jackbeat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/jackbeat
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jackbeat/ChangeLog,v 1.5 2012/05/05 08:30:50 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jackbeat/ChangeLog,v 1.6 2014/06/28 16:32:17 ssuominen Exp $
+
+ 28 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/jackbeat-0.7.6-underlinking.patch, jackbeat-0.7.6.ebuild:
+ Link against gmodule-2.0 libraries wrt #508988 by Gabriel Homeier and Ted
+ Tanberry
05 May 2012; Michał Górny <mgorny@gentoo.org> jackbeat-0.7.6.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -25,4 +30,3 @@
22 Jan 2008; Alexis Ballier <aballier@gentoo.org> +metadata.xml,
+jackbeat-0.6.2.ebuild:
Initial import, thanks to Benjamin Tremoulheac <gentoo@agsp.org>, bug #112199
-
diff --git a/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch b/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch
new file mode 100644
index 000000000000..878929c36693
--- /dev/null
+++ b/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/508988
+
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_symbol'
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_supported'
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_open'
+
+--- configure.ac
++++ configure.ac
+@@ -86,7 +86,7 @@
+ AC_SUBST(PULSE_LIBS)
+ AM_CONDITIONAL(HAVE_PULSE, [test "$have_pulse" = "1"])
+
+-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.12, [have_pkg_gtk=true], true)
++PKG_CHECK_MODULES(GTK, gmodule-2.0 gtk+-2.0 >= 2.12, [have_pkg_gtk=true], true)
+
+ if test x$have_pkg_gtk = xtrue
+ then
diff --git a/media-sound/jackbeat/jackbeat-0.7.6.ebuild b/media-sound/jackbeat/jackbeat-0.7.6.ebuild
index e004eeca99e7..c08a72eb9d48 100644
--- a/media-sound/jackbeat/jackbeat-0.7.6.ebuild
+++ b/media-sound/jackbeat/jackbeat-0.7.6.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jackbeat/jackbeat-0.7.6.ebuild,v 1.2 2012/05/05 08:30:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jackbeat/jackbeat-0.7.6.ebuild,v 1.3 2014/06/28 16:32:17 ssuominen Exp $
-EAPI=4
-
-inherit eutils autotools
+EAPI=5
+inherit autotools eutils
DESCRIPTION="An audio sequencer for Linux"
HOMEPAGE="http://www.samalyse.com/jackbeat/"
-SRC_URI="http://www.samalyse.com/jackbeat/files/${P}.tar.gz"
+SRC_URI="http://www.samalyse.com/${PN}/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -33,10 +32,12 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-automagic-pulse.patch
+ epatch \
+ "${FILESDIR}"/${P}-automagic-pulse.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
# Don't install license file
- sed -i -e "s:help::" pkgdata/Makefile.am
+ sed -i -e 's:help::' pkgdata/Makefile.am || die
eautoreconf
}