summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-09-15 12:55:47 +0000
committerSamuli Suominen <drac@gentoo.org>2007-09-15 12:55:47 +0000
commitb1514a62f0a3c3cc02b2075ca41ba11d9cbd29cd (patch)
tree3554d6079ffd53cabf815b8e1e6c917c9a03c7d4 /media-sound/exaile
parentAdded fix to allow test routines to pass on sparc (see bug #141206). (diff)
downloadgentoo-2-b1514a62f0a3c3cc02b2075ca41ba11d9cbd29cd.tar.gz
gentoo-2-b1514a62f0a3c3cc02b2075ca41ba11d9cbd29cd.tar.bz2
gentoo-2-b1514a62f0a3c3cc02b2075ca41ba11d9cbd29cd.zip
Add support for sqlite in Python 2.5, in other words stop depending on pysqlite unconditionally.
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog5
-rw-r--r--media-sound/exaile/exaile-0.2.10-r1.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index ebf3c6597aea..a1f69ce57d14 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.25 2007/08/11 12:34:57 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.26 2007/09/15 12:55:47 drac Exp $
+
+ 15 Sep 2007; Samuli Suominen <drac@gentoo.org> exaile-0.2.10-r1.ebuild:
+ Add support for sqlite support in Python 2.5.
11 Aug 2007; Samuli Suominen <drac@gentoo.org> exaile-0.2.10-r1.ebuild:
Check for xulrunner, firefox or seamonkey USE flag in gnome-python-extras
diff --git a/media-sound/exaile/exaile-0.2.10-r1.ebuild b/media-sound/exaile/exaile-0.2.10-r1.ebuild
index b756ce9a0add..8f659fd32120 100644
--- a/media-sound/exaile/exaile-0.2.10-r1.ebuild
+++ b/media-sound/exaile/exaile-0.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.10-r1.ebuild,v 1.8 2007/08/11 12:36:11 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.10-r1.ebuild,v 1.9 2007/09/15 12:55:47 drac Exp $
inherit eutils fdo-mime multilib python
@@ -19,7 +19,7 @@ IUSE="aac alsa cdparanoia flac gnome ipod libnotify libsexy mad musepack ogg
oss serpentine streamripper vorbis"
RDEPEND=">=dev-python/pygtk-2.8.6
- >=dev-python/pysqlite-2.3.4-r1
+ || ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2.3.4-r1 )
>=media-libs/mutagen-1.6
|| ( >=dev-lang/python-2.5 dev-python/elementtree )
dev-python/dbus-python
@@ -55,6 +55,14 @@ pkg_setup() {
die "libgpod python use-flag not set"
fi
+ if ! has_version ">=dev-python/pysqlite-2.3.4-r1"; then
+ if ! built_with_use ">=dev-lang/python-2.5" sqlite; then
+ eerror "You need to compile dev-lang/python with USE sqlite, or"
+ eerror "install >=dev-python/pysqlite-2.3.4-r1."
+ die "python 2.5 or up with sqlite support or pysqlite 2.3.5 or up required."
+ fi
+ fi
+
if use gnome; then
if ! built_with_use dev-python/gnome-python-extras xulrunner; then
if ! built_with_use dev-python/gnome-python-extras firefox; then