summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-27 23:40:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-27 23:40:39 +0000
commit63149c9f7dd0cf009283147f444fb21ccda36da2 (patch)
tree0ac64730696110d110e6f67f9776531ac1a80e2d /media-sound/esound
parentMasking net-misc/logjam and net-news/straw (diff)
downloadgentoo-2-63149c9f7dd0cf009283147f444fb21ccda36da2.tar.gz
gentoo-2-63149c9f7dd0cf009283147f444fb21ccda36da2.tar.bz2
gentoo-2-63149c9f7dd0cf009283147f444fb21ccda36da2.zip
add patch to fix compilation with USE=debug, bug #248821.
(Portage version: 2.2_rc15/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog6
-rw-r--r--media-sound/esound/esound-0.2.41.ebuild5
-rw-r--r--media-sound/esound/files/esound-0.2.41-debug.patch12
3 files changed, 21 insertions, 2 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index c7c1b481c153..9df67f13aede 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.120 2008/11/23 22:23:41 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.121 2008/11/27 23:40:39 eva Exp $
+
+ 27 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/esound-0.2.41-debug.patch, esound-0.2.41.ebuild:
+ add patch to fix compilation with USE="debug", bug #248821.
*esound-0.2.41 (23 Nov 2008)
diff --git a/media-sound/esound/esound-0.2.41.ebuild b/media-sound/esound/esound-0.2.41.ebuild
index 226f588f7821..d91e34cfb20c 100644
--- a/media-sound/esound/esound-0.2.41.ebuild
+++ b/media-sound/esound/esound-0.2.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.41.ebuild,v 1.1 2008/11/23 22:23:41 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.41.ebuild,v 1.2 2008/11/27 23:40:39 eva Exp $
inherit libtool gnome.org eutils flag-o-matic
@@ -31,6 +31,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-0.2.39-fix-errno.patch"
+
+ # Fix compilation with USE="debug"
+ epatch "${FILESDIR}/${P}-debug.patch"
}
src_compile() {
diff --git a/media-sound/esound/files/esound-0.2.41-debug.patch b/media-sound/esound/files/esound-0.2.41-debug.patch
new file mode 100644
index 000000000000..ece4f76f806f
--- /dev/null
+++ b/media-sound/esound/files/esound-0.2.41-debug.patch
@@ -0,0 +1,12 @@
+diff -u -r esound-0.2.41.old/clients.c esound-0.2.41/clients.c
+--- esound-0.2.41.old/clients.c 2008-11-26 20:01:03.000000000 +0200
++++ esound-0.2.41/clients.c 2008-11-26 20:01:47.000000000 +0200
+@@ -175,6 +175,8 @@
+ ESDBG_TRACE(
+ if (esd_use_tcpip) {
+
++ unsigned long addr;
++
+ port = ntohs( incoming.sin_port );
+ addr = ntohl( incoming.sin_addr.s_addr );
+