summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-01 18:51:56 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-01 18:51:56 +0000
commit34ee653d45d63909254365ae68729291c861d988 (patch)
tree693e022a605aa9709f1eee514d203602fe2fc2ed /media-sound/darkice/darkice-0.14.ebuild
parentChangeLog fix (Manifest recommit) (diff)
downloadgentoo-2-34ee653d45d63909254365ae68729291c861d988.tar.gz
gentoo-2-34ee653d45d63909254365ae68729291c861d988.tar.bz2
gentoo-2-34ee653d45d63909254365ae68729291c861d988.zip
Version bumped.
Diffstat (limited to 'media-sound/darkice/darkice-0.14.ebuild')
-rw-r--r--media-sound/darkice/darkice-0.14.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/darkice/darkice-0.14.ebuild b/media-sound/darkice/darkice-0.14.ebuild
new file mode 100644
index 000000000000..3026513f3a29
--- /dev/null
+++ b/media-sound/darkice/darkice-0.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.14.ebuild,v 1.1 2004/03/01 18:51:56 mholzer Exp $
+
+IUSE="encode oggvorbis"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="IceCast live streamer delivering Ogg and mp3 streams simulatenously to multiple hosts."
+HOMEPAGE="http://darkice.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+
+DEPEND="encode? ( >=media-sound/lame-1.89 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )"
+
+src_compile() {
+ local myconf=""
+
+ if [ ! "`use encode`" ] && [ ! "`use oggvorbis`" ]
+ then
+
+ eerror "You need support for mp3 or Ogg Vorbis enconding for this"
+ eerror "package. Please merge again with at least one of the "
+ eerror "\`encode' and \`oggvorbis' USE flags enabled:"
+ eerror
+ eerror " # USE=\"encode\" emerge darkice"
+ eerror " # USE=\"oggvorbis\" emerge darkice"
+ die "Won't build without support for lame nor vorbis"
+ fi
+
+ use encode || myconf="--without-lame"
+ use oggvorbis || myconf="--without-vorbis"
+
+ econf ${myconf}
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall darkicedocdir=${D}/usr/share/doc/${PF} || die
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+}