summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 15:15:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 15:15:33 +0000
commitdde842e9169202f5070d0ff0d3be32b454cec0dd (patch)
treeb3d5a66a09d559dc2abd26eba1b4f83954626e1e /media-sound/audiocompress
parentInitial commit. Needed by media-sound/gmusicbrowser (#249869) (diff)
downloadgentoo-2-dde842e9169202f5070d0ff0d3be32b454cec0dd.tar.gz
gentoo-2-dde842e9169202f5070d0ff0d3be32b454cec0dd.tar.bz2
gentoo-2-dde842e9169202f5070d0ff0d3be32b454cec0dd.zip
version bump, honour cflags/ldflags and build with asneeded, bug #247821
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/audiocompress')
-rw-r--r--media-sound/audiocompress/ChangeLog10
-rw-r--r--media-sound/audiocompress/audiocompress-2.0.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/media-sound/audiocompress/ChangeLog b/media-sound/audiocompress/ChangeLog
index 53c59b140f38..2fe95b0837f9 100644
--- a/media-sound/audiocompress/ChangeLog
+++ b/media-sound/audiocompress/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audiocompress
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/ChangeLog,v 1.19 2007/03/09 04:23:51 beandog Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/ChangeLog,v 1.20 2008/12/19 15:15:33 aballier Exp $
+
+*audiocompress-2.0 (19 Dec 2008)
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +audiocompress-2.0.ebuild:
+ version bump, honour cflags/ldflags and build with asneeded, bug #247821
*audiocompress-1.5.2-r1 (09 Mar 2007)
diff --git a/media-sound/audiocompress/audiocompress-2.0.ebuild b/media-sound/audiocompress/audiocompress-2.0.ebuild
new file mode 100644
index 000000000000..b8483bd454b1
--- /dev/null
+++ b/media-sound/audiocompress/audiocompress-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-2.0.ebuild,v 1.1 2008/12/19 15:15:33 aballier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+MY_P="AudioCompress-${PV}"
+DESCRIPTION="Very gentle 1-band dynamic range compressor"
+HOMEPAGE="http://beesbuzz.biz/code/"
+SRC_URI="http://beesbuzz.biz/code/audiocompress/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="esd"
+
+DEPEND="esd? ( media-sound/esound )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ echo "AudioCompress: AudioCompress.o compress.o" > Makefile
+ use esd && append-flags "-DUSE_ESD `esd-config --cflags`"
+ tc-export CC
+ emake LDLIBS="$(use esd && echo `esd-config --libs`)" || die
+}
+
+src_install() {
+ dobin AudioCompress || die
+ dodoc ChangeLog README TODO
+}