summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-19 07:09:32 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-19 07:09:32 +0000
commit93e702a77a639de98451fb8c363c42370178fb44 (patch)
tree4d1c7c5f1384907367f040fbb3697a7d1264bd23 /media-sound/audacity
parentVersion bump. (diff)
downloadgentoo-2-93e702a77a639de98451fb8c363c42370178fb44.tar.gz
gentoo-2-93e702a77a639de98451fb8c363c42370178fb44.tar.bz2
gentoo-2-93e702a77a639de98451fb8c363c42370178fb44.zip
Version bumped. Removed ~ppc and ~sparc for dependency.
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog10
-rw-r--r--media-sound/audacity/audacity-1.3.3.ebuild90
-rw-r--r--media-sound/audacity/files/audacity-1.3.3+flac-1.1.3.patch121
-rw-r--r--media-sound/audacity/files/audacity-1.3.3-gentoo.patchbin0 -> 18178 bytes
-rw-r--r--media-sound/audacity/files/digest-audacity-1.3.33
5 files changed, 223 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 186039cbda91..b848fa434fbd 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.63 2007/05/17 04:32:08 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.64 2007/05/19 07:09:32 matsuu Exp $
+
+*audacity-1.3.3 (19 May 2007)
+
+ 19 May 2007; MATSUU Takuto <matsuu@gentoo.org>
+ +files/audacity-1.3.3+flac-1.1.3.patch,
+ +files/audacity-1.3.3-gentoo.patch, +audacity-1.3.3.ebuild:
+ Version bumped.
+ Removed ~ppc64 and ~sparc for dependency(media-libs/libsoundtouch).
17 May 2007; Joseph Jezak <josejx@gentoo.org> audacity-1.3.2-r1.ebuild:
Marked ppc stable for bug #167126.
diff --git a/media-sound/audacity/audacity-1.3.3.ebuild b/media-sound/audacity/audacity-1.3.3.ebuild
new file mode 100644
index 000000000000..8b3fff95a792
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.3.ebuild,v 1.1 2007/05/19 07:09:32 matsuu Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit eutils autotools wxwidgets
+
+IUSE="flac ladspa libsamplerate mp3 unicode vorbis"
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ >=app-arch/zip-2.3
+ dev-libs/expat
+ >=media-libs/libsndfile-1.0.0
+ >=media-libs/libsoundtouch-1.3.1
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b
+ media-libs/libid3tag )
+ flac? ( media-libs/flac )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )"
+RDEPEND="${DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+
+S="${WORKDIR}/${MY_P}-beta"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}+flac-1.1.3.patch"
+
+ eautoreconf || die
+}
+
+src_compile() {
+ local myconf
+ WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+
+ myconf="${myconf} --with-libsndfile=system"
+ myconf="${myconf} --with-libexpat=system"
+ myconf="${myconf} --with-libsoundtouch=system"
+
+ if use libsamplerate ; then
+ myconf="${myconf} --with-libsamplerate=system --without-libresample"
+ else
+ myconf="${myconf} --without-libsamplerate" # --with-libresample=local
+ fi
+
+ econf \
+ $(use_enable unicode) \
+ $(use_with ladspa) \
+ $(use_with vorbis vorbis system) \
+ $(use_with mp3 libmad system) \
+ $(use_with mp3 id3tag system) \
+ $(use_with flac flac system) \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+
+ insinto /usr/share/audacity/
+ newins images/AudacityLogo48x48.xpm audacity.xpm
+}
diff --git a/media-sound/audacity/files/audacity-1.3.3+flac-1.1.3.patch b/media-sound/audacity/files/audacity-1.3.3+flac-1.1.3.patch
new file mode 100644
index 000000000000..11b1128c6cc8
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.3+flac-1.1.3.patch
@@ -0,0 +1,121 @@
+diff -Naur audacity-src-1.3.3-beta.orig/acinclude.m4 audacity-src-1.3.3-beta/acinclude.m4
+--- audacity-src-1.3.3-beta.orig/acinclude.m4 2007-05-18 13:56:02.000000000 +0900
++++ audacity-src-1.3.3-beta/acinclude.m4 2007-05-19 13:37:01.000000000 +0900
+@@ -479,7 +479,7 @@
+ dnl See if FLAC is installed in the system
+
+ AC_CHECK_LIB(FLAC,
+- FLAC__file_decoder_new,
++ FLAC__stream_decoder_new,
+ lib_found="yes",
+ lib_found="no",
+ -lFLAC++ -lFLAC)
+diff -Naur audacity-src-1.3.3-beta.orig/src/export/ExportFLAC.cpp audacity-src-1.3.3-beta/src/export/ExportFLAC.cpp
+--- audacity-src-1.3.3-beta.orig/src/export/ExportFLAC.cpp 2007-05-18 13:55:50.000000000 +0900
++++ audacity-src-1.3.3-beta/src/export/ExportFLAC.cpp 2007-05-19 13:41:16.000000000 +0900
+@@ -145,6 +145,13 @@
+
+ #define SAMPLES_PER_RUN 8192
+
++/* FLACPP_API_VERSION_CURRENT is 6 for libFLAC++ from flac-1.1.3 (see <FLAC++/export.h>) */
++#if !defined FLACPP_API_VERSION_CURRENT || FLACPP_API_VERSION_CURRENT < 6
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ static struct
+ {
+ bool do_exhaustive_model_search;
+@@ -229,7 +236,9 @@
+ gPrefs->Read(wxT("/FileFormats/FLACBitDepth"), wxT("16"));
+
+ FLAC::Encoder::File *encoder= new FLAC::Encoder::File();
++#ifdef LEGACY_FLAC
+ encoder->set_filename(OSFILENAME(fName));
++#endif
+ encoder->set_channels(numChannels);
+ encoder->set_sample_rate(int(rate + 0.5));
+
+@@ -264,7 +273,11 @@
+ encoder->set_rice_parameter_search_dist(flacLevels[levelPref].rice_parameter_search_dist);
+ encoder->set_max_lpc_order(flacLevels[levelPref].max_lpc_order);
+
++#ifdef LEGACY_FLAC
+ encoder->init();
++#else
++ encoder->init(OSFILENAME(fName));
++#endif
+
+ int numWaveTracks;
+ WaveTrack **waveTracks;
+@@ -343,7 +356,7 @@
+ return new ExportFLAC();
+ }
+
+-#endif // USE_LIBVORBIS
++#endif // USE_LIBFLAC
+
+ // Indentation settings for Vim and Emacs and unique identifier for Arch, a
+ // version control system. Please do not modify past this point.
+diff -Naur audacity-src-1.3.3-beta.orig/src/import/ImportFLAC.cpp audacity-src-1.3.3-beta/src/import/ImportFLAC.cpp
+--- audacity-src-1.3.3-beta.orig/src/import/ImportFLAC.cpp 2007-05-18 13:55:53.000000000 +0900
++++ audacity-src-1.3.3-beta/src/import/ImportFLAC.cpp 2007-05-19 13:37:01.000000000 +0900
+@@ -63,6 +63,13 @@
+ #include "../WaveTrack.h"
+ #include "ImportPlugin.h"
+
++/* FLACPP_API_VERSION_CURRENT is 6 for libFLAC++ from flac-1.1.3 (see <FLAC++/export.h>) */
++#if !defined FLACPP_API_VERSION_CURRENT || FLACPP_API_VERSION_CURRENT < 6
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ class FLACImportFileHandle;
+
+ class MyFLACFile : public FLAC::Decoder::File
+@@ -273,6 +280,7 @@
+
+ bool FLACImportFileHandle::Init()
+ {
++#ifdef LEGACY_FLAC
+ bool success = mFile->set_filename(OSFILENAME(mName));
+ if (!success) {
+ return false;
+@@ -281,11 +289,23 @@
+ if (state != FLAC__FILE_DECODER_OK) {
+ return false;
+ }
++#else
++ if (mFile->init(OSFILENAME(mName)) != FLAC__STREAM_DECODER_INIT_STATUS_OK) {
++ return false;
++ }
++#endif
+ mFile->process_until_end_of_metadata();
++#ifdef LEGACY_FLAC
+ state = mFile->get_state();
+ if (state != FLAC__FILE_DECODER_OK) {
+ return false;
+ }
++#else
++ // not necessary to check state, error callback will catch errors, but here's how:
++ if (mFile->get_state() > FLAC__STREAM_DECODER_READ_FRAME) {
++ return false;
++ }
++#endif
+ if (!mFile->is_valid() || mFile->get_was_error())
+ {
+ // This probably is not a FLAC file at all
+@@ -349,7 +369,11 @@
+ mChannels[1]->SetTeamed(true);
+ }
+
++#ifdef LEGACY_FLAC
+ mFile->process_until_end_of_file();
++#else
++ mFile->process_until_end_of_stream();
++#endif
+
+ *outTracks = new Track *[*outNumTracks];
+ for(c = 0; c < *outNumTracks; c++) {
diff --git a/media-sound/audacity/files/audacity-1.3.3-gentoo.patch b/media-sound/audacity/files/audacity-1.3.3-gentoo.patch
new file mode 100644
index 000000000000..76aa5684be9b
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.3-gentoo.patch
Binary files differ
diff --git a/media-sound/audacity/files/digest-audacity-1.3.3 b/media-sound/audacity/files/digest-audacity-1.3.3
new file mode 100644
index 000000000000..061f5cb2cc0e
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.3.3
@@ -0,0 +1,3 @@
+MD5 72a9e3239f3b5af63030a1e1b07e40e7 audacity-src-1.3.3.tar.gz 6649291
+RMD160 ca0099bd00af8c863834b56b64c26b6a54a9e8b0 audacity-src-1.3.3.tar.gz 6649291
+SHA256 9a3e58c3ce04e5b1d743891bc7af6a2a22f01e846111af560def6a6cb360729d audacity-src-1.3.3.tar.gz 6649291