summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-26 21:22:53 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-26 21:22:53 +0000
commit518971c1f2a4232cfdce83b3163cfbc4237ce864 (patch)
tree54f176e49062abfb4d62a9887658cde106ba49ab /media-sound/audacity
parenttaking this package (diff)
downloadgentoo-2-518971c1f2a4232cfdce83b3163cfbc4237ce864.tar.gz
gentoo-2-518971c1f2a4232cfdce83b3163cfbc4237ce864.tar.bz2
gentoo-2-518971c1f2a4232cfdce83b3163cfbc4237ce864.zip
Add patch to fix build errors with recent versions of ffmpeg (bug #341927 by Sven E.).
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog7
-rw-r--r--media-sound/audacity/audacity-1.3.12.ebuild3
-rw-r--r--media-sound/audacity/files/audacity-1.3.12-ffmpeg.patch52
3 files changed, 60 insertions, 2 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index d024b71a1e03..c0511e776d7b 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.142 2010/10/04 08:52:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.143 2010/10/26 21:22:53 radhermit Exp $
+
+ 26 Oct 2010; Tim Harder <radhermit@gentoo.org> audacity-1.3.12.ebuild,
+ +files/audacity-1.3.12-ffmpeg.patch:
+ Add patch to fix build errors with recent versions of ffmpeg (bug #341927
+ by Sven E.).
04 Oct 2010; Ryan Hill <dirtyepic@gentoo.org> audacity-1.3.12.ebuild,
files/audacity-1.3.12-automagic.patch, +files/audacity-1.3.12-gcc45.patch:
diff --git a/media-sound/audacity/audacity-1.3.12.ebuild b/media-sound/audacity/audacity-1.3.12.ebuild
index 7182eba25e8a..0f5c0cde8059 100644
--- a/media-sound/audacity/audacity-1.3.12.ebuild
+++ b/media-sound/audacity/audacity-1.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.12.ebuild,v 1.2 2010/10/04 08:52:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.12.ebuild,v 1.3 2010/10/26 21:22:53 radhermit Exp $
EAPI=2
@@ -50,6 +50,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}/${PN}-1.3.12-automagic.patch"
epatch "${FILESDIR}/${PN}-1.3.12-gcc45.patch"
+ epatch "${FILESDIR}/${PN}-1.3.12-ffmpeg.patch"
AT_M4DIR="${S}/m4" eautoreconf
}
diff --git a/media-sound/audacity/files/audacity-1.3.12-ffmpeg.patch b/media-sound/audacity/files/audacity-1.3.12-ffmpeg.patch
new file mode 100644
index 000000000000..22146bb1bbff
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.12-ffmpeg.patch
@@ -0,0 +1,52 @@
+--- audacity-src-1.3.12-beta.orig/src/FFmpeg.cpp 2010-03-30 04:28:54.000000000 -0700
++++ audacity-src-1.3.12-beta/src/FFmpeg.cpp 2010-10-26 12:22:02.145695409 -0700
+@@ -204,7 +204,11 @@
+ return ret;
+ }
+
++#if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52, 68, 0)
++static int ufile_write(URLContext *h, const unsigned char *buf, int size)
++#else
+ static int ufile_write(URLContext *h, unsigned char *buf, int size)
++#endif
+ {
+ return (int) ((wxFile *) h->priv_data)->Write(buf, size);
+ }
+@@ -356,7 +360,11 @@
+ }
+ // Otherwize, resort to extension matching if available
+ else if (fmt1->extensions) {
++#if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52, 60, 0)
++ if (FFmpegLibsInst->av_match_ext(filename, fmt1->extensions)) {
++#else
+ if (FFmpegLibsInst->match_ext(filename, fmt1->extensions)) {
++#endif
+ score = 50;
+ }
+ }
+@@ -829,7 +837,11 @@
+ INITDYN(avformat,av_open_input_file);
+ INITDYN(avformat,av_open_input_stream);
+ INITDYN(avformat,get_buffer);
++#if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52, 60, 0)
++ INITDYN(avformat,av_match_ext);
++#else
+ INITDYN(avformat,match_ext);
++#endif
+
+ #if FFMPEG_STABLE
+ INITDYN(avformat,av_init_packet);
+--- audacity-src-1.3.12-beta.orig/src/FFmpeg.h 2010-03-30 04:28:54.000000000 -0700
++++ audacity-src-1.3.12-beta/src/FFmpeg.h 2010-10-26 12:23:02.618168997 -0700
+@@ -224,7 +224,11 @@
+ AVStream* (*av_new_stream) (AVFormatContext *s, int id);
+ AVFormatContext* (*av_alloc_format_context) (void);
+ AVOutputFormat* (*guess_format) (const char *short_name, const char *filename, const char *mime_type);
++#if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52, 60, 0)
++ int (*av_match_ext) (const char *filename, const char *extensions);
++#else
+ int (*match_ext) (const char *filename, const char *extensions);
++#endif
+ int (*av_write_trailer) (AVFormatContext *s);
+ int (*av_interleaved_write_frame) (AVFormatContext *s, AVPacket *pkt);
+ int (*av_write_frame) (AVFormatContext *s, AVPacket *pkt);