summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-12-03 15:50:48 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-12-03 15:50:48 +0000
commitca66a5539de4ffae238b7356831f665ed40a97df (patch)
treeb464c3ac4b489d50a6372cedc95f2e00b936d858 /media-sound/audacious
parentVersion bump. (diff)
downloadgentoo-2-ca66a5539de4ffae238b7356831f665ed40a97df.tar.gz
gentoo-2-ca66a5539de4ffae238b7356831f665ed40a97df.tar.bz2
gentoo-2-ca66a5539de4ffae238b7356831f665ed40a97df.zip
Version bump. Made D-Bus warning more explicit.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-1.4.3.ebuild72
-rw-r--r--media-sound/audacious/files/digest-audacious-1.4.36
3 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index a82c2d96ba7e..213effdc1673 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.131 2007/11/21 17:48:20 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.132 2007/12/03 15:50:47 chainsaw Exp $
+
+*audacious-1.4.3 (03 Dec 2007)
+
+ 03 Dec 2007; Tony Vroon <chainsaw@gentoo.org> +audacious-1.4.3.ebuild:
+ Version bump. Made D-Bus warning more explicit.
21 Nov 2007; Tony Vroon <chainsaw@gentoo.org> audacious-1.4.2.ebuild:
Explicitly block audacious-plugins-ugly, it is no longer supported upstream
diff --git a/media-sound/audacious/audacious-1.4.3.ebuild b/media-sound/audacious/audacious-1.4.3.ebuild
new file mode 100644
index 000000000000..d98dd281bf9a
--- /dev/null
+++ b/media-sound/audacious/audacious-1.4.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.4.3.ebuild,v 1.1 2007/12/03 15:50:47 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet dbus nls libsamplerate"
+
+RDEPEND="dbus? ( >=dev-libs/dbus-glib-0.60 )
+ libsamplerate? ( media-libs/libsamplerate )
+ >=dev-libs/libmcs-0.6.0
+ >=dev-libs/libmowgli-0.5.0
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.10"
+
+DEPEND="${RDEPEND}
+ !media-plugins/audacious-plugins-ugly
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.4.2"
+
+src_compile() {
+ econf \
+ $(use_enable chardet) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.4"
+ elog "Plugins compiled against 1.3 will not be loaded."
+ if ! useq dbus ; then
+ eerror "Unsupported configuration: D-Bus disabled"
+ ewarn "D-Bus has been disabled. Note that audtool will not be provided, you will not"
+ ewarn "be to able to get song information from scripts or control the player remotely."
+ ewarn "This configuration is provided for people heavily opposed to D-Bus that are able "
+ ewarn "to live with the loss of functionality that this implies. Reports about remote "
+ ewarn "control or multiple instances of Audacious being launched will be *closed*."
+ else
+ elog "Remote control is now only provided over D-Bus. Audacious offers both a private "
+ elog "interface and an MPRIS compliant interface on the bus. The older interface using "
+ elog "beepctrl.h is no longer present."
+ fi
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.4.3 b/media-sound/audacious/files/digest-audacious-1.4.3
new file mode 100644
index 000000000000..1b6ab3f00393
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.4.3
@@ -0,0 +1,6 @@
+MD5 114b94e95394b5d43d48e1caf7013e61 audacious-1.4.3.tgz 1839412
+RMD160 7d1b11846df9f2d298a81f249f96db3f467610e1 audacious-1.4.3.tgz 1839412
+SHA256 a489c79135a87cc9511977dcbd4e6baf21ced36f8416b5312c7f3ad6714eb246 audacious-1.4.3.tgz 1839412
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839