summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-10 14:51:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-10 14:51:55 +0000
commit4f098131c9b2f7664c0b826ecba997c59d6b088d (patch)
treedd619545c144345c77023a6d8156be90ddda6c3b /media-sound/audacious
parentMasked amule for security Bug #134792. (diff)
downloadgentoo-2-4f098131c9b2f7664c0b826ecba997c59d6b088d.tar.gz
gentoo-2-4f098131c9b2f7664c0b826ecba997c59d6b088d.tar.bz2
gentoo-2-4f098131c9b2f7664c0b826ecba997c59d6b088d.zip
dont warning about mp3 stuff when USE=mp3
(Portage version: 2.1)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/audacious-1.0.0-r1.ebuild67
-rw-r--r--media-sound/audacious/audacious-1.1.0_beta1.ebuild20
2 files changed, 46 insertions, 41 deletions
diff --git a/media-sound/audacious/audacious-1.0.0-r1.ebuild b/media-sound/audacious/audacious-1.0.0-r1.ebuild
index 9eab3b704ffc..f95285525a1e 100644
--- a/media-sound/audacious/audacious-1.0.0-r1.ebuild
+++ b/media-sound/audacious/audacious-1.0.0-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.0.0-r1.ebuild,v 1.3 2006/06/06 15:13:37 chainsaw Exp $
-
-IUSE="aac alsa arts esd flac gnome jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma"
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.0.0-r1.ebuild,v 1.4 2006/06/10 14:51:55 vapier Exp $
inherit flag-o-matic
-DESCRIPTION="Audacious Player - Your music, your way, no exceptions."
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
HOMEPAGE="http://audacious-media-player.org/"
SRC_URI="http://audacious-media-player.org/release/${P}.tgz
mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~alpha amd64 ~hppa ~mips ppc ~ppc64 ~sparc ~x86"
+IUSE="aac alsa arts esd flac gnome jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma"
RDEPEND="app-arch/unzip
net-misc/curl
@@ -41,15 +39,20 @@ RDEPEND="app-arch/unzip
timidity? ( media-sound/timidity++ )
vorbis? ( >=media-libs/libvorbis-1.0
>=media-libs/libogg-1.0 )"
-
DEPEND="${RDEPEND}
nls? ( dev-util/intltool )
>=dev-util/pkgconfig-0.9.0"
-src_compile() {
- if ! useq mp3; then
- ewarn "MP3 support is now optional and you have not enabled it."
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
fi
+}
+
+src_compile() {
+ mp3_warning
# Bug #42893
replace-flags "-Os" "-O2"
@@ -59,25 +62,25 @@ src_compile() {
econf \
--with-dev-dsp=/dev/sound/dsp \
--with-dev-mixer=/dev/sound/mixer \
- `use_enable mmx simd` \
- `use_enable gnome gconf` \
- `use_enable vorbis` \
- `use_enable esd` \
- `use_enable mp3` \
- `use_enable nls` \
- `use_enable oss` \
- `use_enable alsa` \
- `use_enable arts` \
- `use_enable flac` \
- `use_enable aac` \
- `use_enable modplug` \
- `use_enable lirc` \
- `use_enable sndfile` \
- `use_enable wma` \
- `use_enable sid` \
- `use_enable musepack` \
- `use_enable jack` \
- `use_enable timidity` \
+ $(use_enable mmx simd) \
+ $(use_enable gnome gconf) \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
|| die
emake || die "make failed"
@@ -89,13 +92,11 @@ src_install() {
# Gentoo_ice skin installation; bug #109772
insinto /usr/share/audacious/Skins/gentoo_ice
- doins ${WORKDIR}/gentoo_ice/*
+ doins "${WORKDIR}"/gentoo_ice/*
docinto gentoo_ice
- dodoc ${WORKDIR}/README
+ dodoc "${WORKDIR}"/README
}
pkg_postinst() {
- echo
- einfo "MP3 support is now optional, you may want to enable the mp3 USE-flag."
- echo
+ mp3_warning
}
diff --git a/media-sound/audacious/audacious-1.1.0_beta1.ebuild b/media-sound/audacious/audacious-1.1.0_beta1.ebuild
index f9f668e2a683..07802c65da36 100644
--- a/media-sound/audacious/audacious-1.1.0_beta1.ebuild
+++ b/media-sound/audacious/audacious-1.1.0_beta1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.1.0_beta1.ebuild,v 1.2 2006/06/08 10:20:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.1.0_beta1.ebuild,v 1.3 2006/06/10 14:51:55 vapier Exp $
inherit flag-o-matic
MY_P="${P/_beta/-dr}"
S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Audacious Player - Your music, your way, no exceptions."
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
HOMEPAGE="http://audacious-media-player.org/"
SRC_URI="http://audacious-media-player.org/beta/${MY_P}.tgz
mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
@@ -45,10 +45,16 @@ DEPEND="${RDEPEND}
nls? ( dev-util/intltool )
>=dev-util/pkgconfig-0.9.0"
-src_compile() {
- if ! useq mp3; then
- ewarn "MP3 support is now optional and you have not enabled it."
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
fi
+}
+
+src_compile() {
+ mp3_warning
# Bug #42893
replace-flags "-Os" "-O2"
@@ -94,7 +100,5 @@ src_install() {
}
pkg_postinst() {
- echo
- einfo "MP3 support is now optional, you may want to enable the mp3 USE-flag"
- echo
+ mp3_warning
}