summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2013-09-02 21:13:01 +0000
committerJeff Horelick <jdhore@gentoo.org>2013-09-02 21:13:01 +0000
commit1f3ca69cbaf2f02aa9020ac15bc9276b20943e5d (patch)
treeffffb7f540ebfde34506337bc64379913d4cb333 /media-sound/audacious/audacious-3.4.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-1f3ca69cbaf2f02aa9020ac15bc9276b20943e5d.tar.gz
gentoo-2-1f3ca69cbaf2f02aa9020ac15bc9276b20943e5d.tar.bz2
gentoo-2-1f3ca69cbaf2f02aa9020ac15bc9276b20943e5d.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'media-sound/audacious/audacious-3.4.1.ebuild')
-rw-r--r--media-sound/audacious/audacious-3.4.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/audacious/audacious-3.4.1.ebuild b/media-sound/audacious/audacious-3.4.1.ebuild
new file mode 100644
index 000000000000..22e7c0415abe
--- /dev/null
+++ b/media-sound/audacious/audacious-3.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.4.1.ebuild,v 1.1 2013/09/02 21:13:01 jdhore Exp $
+
+EAPI=5
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+
+IUSE="chardet nls"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.28
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ x11-libs/gtk+:3"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ chardet? ( >=app-i18n/libguess-1.1 )
+ nls? ( dev-util/intltool )"
+
+PDEPEND="~media-plugins/audacious-plugins-3.4.1"
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable chardet) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}