summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-26 13:49:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-26 13:49:47 +0000
commitb04db3954938957587ccfdc6666f2b322c8a5e47 (patch)
tree00a4847d561b410db2c8db105f9435983319857e /media-sound/aqualung
parentVersion Bump (diff)
downloadgentoo-2-b04db3954938957587ccfdc6666f2b322c8a5e47.tar.gz
gentoo-2-b04db3954938957587ccfdc6666f2b322c8a5e47.tar.bz2
gentoo-2-b04db3954938957587ccfdc6666f2b322c8a5e47.zip
fix build with ffmpeg git
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/aqualung')
-rw-r--r--media-sound/aqualung/ChangeLog9
-rw-r--r--media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild7
-rw-r--r--media-sound/aqualung/files/aqualung-0.9_beta11-libavformat54.patch26
3 files changed, 37 insertions, 5 deletions
diff --git a/media-sound/aqualung/ChangeLog b/media-sound/aqualung/ChangeLog
index 6935d281ad7a..9bfc981030a5 100644
--- a/media-sound/aqualung/ChangeLog
+++ b/media-sound/aqualung/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/aqualung
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aqualung/ChangeLog,v 1.23 2011/11/10 12:18:56 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aqualung/ChangeLog,v 1.24 2012/02/26 13:49:46 aballier Exp $
+
+ 26 Feb 2012; Alexis Ballier <aballier@gentoo.org>
+ aqualung-0.9_beta11-r1.ebuild,
+ +files/aqualung-0.9_beta11-libavformat54.patch:
+ fix build with ffmpeg git
10 Nov 2011; Alexis Ballier <aballier@gentoo.org>
aqualung-0.9_beta11-r1.ebuild, +files/aqualung-0.9_beta11-ffmpeg.patch:
diff --git a/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild b/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild
index d46acb7509b8..7f13bcf57d52 100644
--- a/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild
+++ b/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild,v 1.9 2011/11/10 12:18:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aqualung/aqualung-0.9_beta11-r1.ebuild,v 1.10 2012/02/26 13:49:46 aballier Exp $
EAPI=4
@@ -48,7 +48,8 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_prepare() {
epatch "${FILESDIR}"/${P}-use_lrdf_cflags.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${P}-libavformat54.patch
sed -i \
-e 's:$(pkgdatadir)/doc:/usr/share/doc/${PF}:' \
doc/Makefile.am || die
diff --git a/media-sound/aqualung/files/aqualung-0.9_beta11-libavformat54.patch b/media-sound/aqualung/files/aqualung-0.9_beta11-libavformat54.patch
new file mode 100644
index 000000000000..103f3f28c5b1
--- /dev/null
+++ b/media-sound/aqualung/files/aqualung-0.9_beta11-libavformat54.patch
@@ -0,0 +1,26 @@
+Index: aqualung-0.9beta11/configure.ac
+===================================================================
+--- aqualung-0.9beta11.orig/configure.ac
++++ aqualung-0.9beta11/configure.ac
+@@ -660,7 +660,7 @@ else
+ fi
+ fi
+
+- AC_CHECK_LIB(avformat, av_open_input_file, [avf_lib=yes], [avf_lib=no], [-lavcodec -lavutil -lz])
++ AC_CHECK_LIB(avformat, avformat_open_input, [avf_lib=yes], [avf_lib=no], [-lavcodec -lavutil -lz])
+ AC_CHECK_LIB(avcodec, avcodec_open, [avc_lib=yes], [avc_lib=no], [-lavformat -lavutil -lz])
+
+ if test "$avc_hdr" = "yes" -a "$avf_hdr" = "yes" -a "$avc_lib" = "yes" -a "$avf_lib" = "yes" ; then
+Index: aqualung-0.9beta11/src/decoder/dec_lavc.c
+===================================================================
+--- aqualung-0.9beta11.orig/src/decoder/dec_lavc.c
++++ aqualung-0.9beta11/src/decoder/dec_lavc.c
+@@ -111,7 +111,7 @@ lavc_decoder_open(decoder_t * dec, char
+ file_decoder_t * fdec = dec->fdec;
+ int i;
+
+- if (av_open_input_file(&pd->avFormatCtx, filename, NULL, 0, NULL) != 0)
++ if (avformat_open_input(&pd->avFormatCtx, filename, NULL, NULL) != 0)
+ return DECODER_OPEN_BADLIB;
+
+ if (av_find_stream_info(pd->avFormatCtx) < 0)