summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-02 08:41:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-02 08:41:40 +0000
commitc644bb703004824e0e6eec4057c674c242d13dbd (patch)
treea6c9d973dd925d484656ea6b0be430b1d651243b /media-sound/amarok
parentCleanup old versions (diff)
downloadgentoo-2-c644bb703004824e0e6eec4057c674c242d13dbd.tar.gz
gentoo-2-c644bb703004824e0e6eec4057c674c242d13dbd.tar.bz2
gentoo-2-c644bb703004824e0e6eec4057c674c242d13dbd.zip
Add micro-fix for podcasts, as reported by jaervosz.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog6
-rw-r--r--media-sound/amarok/amarok-1.4.4.ebuild4
-rw-r--r--media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch17
3 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 66ae52ee6511..5ee88010b411 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.171 2006/10/27 18:41:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.172 2006/11/02 08:41:40 flameeyes Exp $
+
+ 02 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/amarok-1.4.4-podcast-fix.patch, amarok-1.4.4.ebuild:
+ Add micro-fix for podcasts, as reported by jaervosz.
*amarok-1.4.4 (27 Oct 2006)
diff --git a/media-sound/amarok/amarok-1.4.4.ebuild b/media-sound/amarok/amarok-1.4.4.ebuild
index fb6b0f618492..0226147544f9 100644
--- a/media-sound/amarok/amarok-1.4.4.ebuild
+++ b/media-sound/amarok/amarok-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4.ebuild,v 1.1 2006/10/27 18:41:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4.ebuild,v 1.2 2006/11/02 08:41:40 flameeyes Exp $
LANGS="af ar az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it
ja ka km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sk sl sq sr sr@Latn sv ta tg
@@ -52,6 +52,8 @@ DEPEND="${DEPEND}
need-kde 3.3
+PATCHES="${FILESDIR}/${P}-podcast-fix.patch"
+
src_compile() {
append-flags -fno-inline
diff --git a/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch b/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch
new file mode 100644
index 000000000000..26a5974b5bc1
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.4-podcast-fix.patch
@@ -0,0 +1,17 @@
+Index: amarok-1.4.4/amarok/src/playlistbrowseritem.cpp
+===================================================================
+--- amarok-1.4.4.orig/amarok/src/playlistbrowseritem.cpp
++++ amarok-1.4.4/amarok/src/playlistbrowseritem.cpp
+@@ -2051,10 +2051,10 @@ PodcastChannel::episodeExists( const QDo
+ }
+
+ QString episodeTitle = xml.namedItem( "title" ).toElement().text();
+- QString episodeURL = xml.namedItem( "enclosure" ).toElement().attribute( "url" );
++ KURL episodeURL = xml.namedItem( "enclosure" ).toElement().attribute( "url" );
+ command = QString("SELECT id FROM podcastepisodes WHERE parent='%1' AND url='%2' AND title='%3';")
+ .arg( CollectionDB::instance()->escapeString( url().url() ),
+- CollectionDB::instance()->escapeString( episodeURL ),
++ CollectionDB::instance()->escapeString( episodeURL.url() ),
+ CollectionDB::instance()->escapeString( episodeTitle ) );
+ QStringList values = CollectionDB::instance()->query( command );
+ return !values.isEmpty();