summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 16:21:45 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 16:21:45 +0000
commit262fccfbcd82d3a1503a790e5f003ffe89bde88c (patch)
treec3b7fbf7bcbeb843d6caa845274815dc1926ffb5 /media-sound/amarok
parentHandle USB devices better (bug #356215) (diff)
downloadgentoo-2-262fccfbcd82d3a1503a790e5f003ffe89bde88c.tar.gz
gentoo-2-262fccfbcd82d3a1503a790e5f003ffe89bde88c.tar.bz2
gentoo-2-262fccfbcd82d3a1503a790e5f003ffe89bde88c.zip
Bumped amarok to the 2.4.1 release.
Renamed the patch to fix the upnp detection. (Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog10
-rw-r--r--media-sound/amarok/amarok-2.4.0.90.ebuild4
-rw-r--r--media-sound/amarok/amarok-2.4.1.ebuild159
-rw-r--r--media-sound/amarok/files/amarok-fix-upnp-dep.patch37
4 files changed, 207 insertions, 3 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 2df45a9e2dcc..427b401d36d7 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.404 2011/04/26 22:03:26 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.405 2011/05/08 16:21:45 jmbsvicetto Exp $
+
+*amarok-2.4.1 (08 May 2011)
+
+ 08 May 2011; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ amarok-2.4.0.90.ebuild, +amarok-2.4.1.ebuild,
+ +files/amarok-fix-upnp-dep.patch:
+ Bumped amarok to the 2.4.1 release.
+ Renamed the patch to fix the upnp detection.
26 Apr 2011; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
amarok-2.4.0.90.ebuild:
diff --git a/media-sound/amarok/amarok-2.4.0.90.ebuild b/media-sound/amarok/amarok-2.4.0.90.ebuild
index a3beac142591..06b94c0db33e 100644
--- a/media-sound/amarok/amarok-2.4.0.90.ebuild
+++ b/media-sound/amarok/amarok-2.4.0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.4.0.90.ebuild,v 1.4 2011/04/26 22:03:26 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.4.0.90.ebuild,v 1.5 2011/05/08 16:21:45 jmbsvicetto Exp $
EAPI="3"
@@ -79,7 +79,7 @@ RDEPEND="${COMMONDEPEND}
# Upstream patch to fix the plugin detection on startup
# https://projects.kde.org/projects/extragear/multimedia/amarok/repository/revisions/37eda947bd8181a73ad0fffc88e66c25ddd69f28
PATCHES=(
- "${FILESDIR}/${P}-fix-upnp-dep.patch"
+ "${FILESDIR}/${PN}-fix-upnp-dep.patch"
"${FILESDIR}/${P}-fix-plugin-detection.patch"
)
diff --git a/media-sound/amarok/amarok-2.4.1.ebuild b/media-sound/amarok/amarok-2.4.1.ebuild
new file mode 100644
index 000000000000..1b91eb3fcb82
--- /dev/null
+++ b/media-sound/amarok/amarok-2.4.1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.4.1.ebuild,v 1.1 2011/05/08 16:21:45 jmbsvicetto Exp $
+
+EAPI="3"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca cs da de en_GB es et eu fi fr hu it ja km nb nds nl
+ pa pl pt pt_BR ru sl sr sr@latin sv th tr uk wa zh_TW"
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ KDE_SCM="git"
+ KEYWORDS=""
+fi
+
+KDE_REQUIRED="never"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda daap debug +embedded handbook ipod lastfm mp3tunes mtp opengl playdar +player semantic-desktop upnp +utils"
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ player? (
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ $(add_kdebase_dep kdelibs 'opengl?,semantic-desktop?')
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ $(add_kdebase_dep kdemultimedia-kioslaves)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ opengl? ( virtual/opengl )
+ playdar? ( dev-libs/qjson )
+ upnp? ( kde-misc/kio-upnp-ms )
+ )
+ utils? (
+ x11-libs/qt-core
+ x11-libs/qt-dbus
+ )
+ !player? ( !utils? ( media-sound/amarok[player] ) )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ player? ( $(add_kdebase_dep phonon-kde) )
+"
+
+# Upstream patch to fix the plugin detection on startup
+# https://projects.kde.org/projects/extragear/multimedia/amarok/repository/revisions/37eda947bd8181a73ad0fffc88e66c25ddd69f28
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-upnp-dep.patch"
+)
+
+src_prepare() {
+ if ! use player; then
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ if use player; then
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with playdar QJSON)
+ $(cmake-utils_use_with upnp HUpnp)
+ )
+ else
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ )
+ fi
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use player; then
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-fix-upnp-dep.patch b/media-sound/amarok/files/amarok-fix-upnp-dep.patch
new file mode 100644
index 000000000000..878c013fa972
--- /dev/null
+++ b/media-sound/amarok/files/amarok-fix-upnp-dep.patch
@@ -0,0 +1,37 @@
+diff -urN amarok-2.4.0.90.orig/CMakeLists.txt amarok-2.4.0.90/CMakeLists.txt
+--- amarok-2.4.0.90.orig/CMakeLists.txt 2011-04-19 00:03:27.910000016 +0000
++++ amarok-2.4.0.90/CMakeLists.txt 2011-04-19 00:06:17.466666683 +0000
+@@ -105,6 +105,10 @@
+ macro_optional_find_package(QJSON)
+ macro_log_feature( QJSON_FOUND "QJson" "Qt JSON Parser used for the Playdar Collection" "http://qjson.sourceforge.net/" FALSE "" "" )
+
++ # HUpnp is required for the upnp plugin
++ macro_optional_find_package(HUpnp)
++ macro_log_feature ( HUPNP_FOUND "HUpnp" "HUpnp is an universal Plug and Play Library" "http://herqq.org/" FALSE "" "" )
++
+ # macro_optional_find_package(Strigi)
+ # macro_log_feature( STRIGI_FOUND "strigi" "Index metadata of files" "http://strigi.sourceforge.net" FALSE "" "" )
+
+diff -urN amarok-2.4.0.90.orig/src/core-impl/collections/CMakeLists.txt amarok-2.4.0.90/src/core-impl/collections/CMakeLists.txt
+--- amarok-2.4.0.90.orig/src/core-impl/collections/CMakeLists.txt 2011-04-19 00:03:27.940000015 +0000
++++ amarok-2.4.0.90/src/core-impl/collections/CMakeLists.txt 2011-04-19 00:07:06.753333348 +0000
+@@ -25,4 +25,6 @@
+ if( QJSON_FOUND )
+ add_subdirectory( playdarcollection )
+ endif( QJSON_FOUND )
+-add_subdirectory( upnpcollection )
++if( HUPNP_FOUND )
++ add_subdirectory( upnpcollection )
++endif( HUPNP_FOUND )
+diff -urN amarok-2.4.0.90.orig/cmake/modules/FindHUpnp.cmake amarok-2.4.0.90/cmake/modules/FindHUpnp.cmake
+--- amarok-2.4.0.90.orig/cmake/modules/FindHUpnp.cmake 2011-04-19 01:59:14.313333349 +0000
++++ amarok-2.4.0.90/cmake/modules/FindHUpnp.cmake 2011-04-19 02:14:13.670000016 +0000
+@@ -6,7 +6,7 @@
+ # HUPNP_LIBRARIES
+ # HUPNP_FOUND
+
+-find_path(HUPNP_INCLUDE_DIR HUpnp HINTS ${KDE4_INCLUDE_DIR})
++find_path(HUPNP_INCLUDE_DIR HUpnp HINTS ${KDE4_INCLUDE_DIR} /usr/include/HUpnpCore)
+
+ find_library(HUPNP_LIBRARIES HUpnp PATHS ${KDE4_LIB_DIR})
+