summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-06-06 11:18:44 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-06-06 11:18:44 +0000
commitccba8007e14dcb81766832d581111da55ec0dd30 (patch)
tree05e06361059c82550655cd87f40045ec584294f9 /media-sound/amarok/amarok-1.3_beta1.ebuild
parentchanged use flag (diff)
downloadgentoo-2-ccba8007e14dcb81766832d581111da55ec0dd30.tar.gz
gentoo-2-ccba8007e14dcb81766832d581111da55ec0dd30.tar.bz2
gentoo-2-ccba8007e14dcb81766832d581111da55ec0dd30.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/amarok/amarok-1.3_beta1.ebuild')
-rw-r--r--media-sound/amarok/amarok-1.3_beta1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/amarok/amarok-1.3_beta1.ebuild b/media-sound/amarok/amarok-1.3_beta1.ebuild
new file mode 100644
index 000000000000..a148ce948dac
--- /dev/null
+++ b/media-sound/amarok/amarok-1.3_beta1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta1.ebuild,v 1.1 2005/06/06 11:18:44 lanius Exp $
+
+inherit kde eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="amaroK - the audio player for KDE"
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="arts flac gstreamer kde mad mysql noamazon oggvorbis opengl xine xmms visualization postgres"
+# kde: enables compilation of the konqueror sidebar plugin
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( ( kde-base/kdemultimedia-arts kde-base/akode )
+ kde-base/kdemultimedia ) )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ >=media-libs/tunepimp-0.3.0
+ >=media-libs/taglib-1.3.1
+ gstreamer? ( >=media-libs/gst-plugins-0.8.6
+ mad? ( >=media-plugins/gst-plugins-mad-0.8.6 )
+ oggvorbis? ( >=media-plugins/gst-plugins-ogg-0.8.6
+ >=media-plugins/gst-plugins-vorbis-0.8.6 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.8.6 ) )
+ mysql? ( >=dev-db/mysql-4 )
+ visualization? ( media-libs/libsdl
+ >=media-plugins/libvisual-plugins-0.2 )
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.4
+
+pkg_setup() {
+ if use arts && ! use xine && ! use gstreamer; then
+ ewarn "aRts support is deprecated, if you have problems please consider"
+ ewarn "enabling support for Xine or GStreamer"
+ ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
+ ebeep 2
+ fi
+
+ if ! use arts && ! use xine && ! use gstreamer; then
+ eerror "amaroK needs either aRts (deprecated), Xine or GStreamer to work,"
+ eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
+ die
+ fi
+
+ # check whether kdelibs was compiled with arts support
+ kde_pkg_setup
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="`kde-config --prefix`"
+
+ myconf="$(use_with arts) $(use_with xine)
+ $(use_with gstreamer) $(use_enable mysql)
+ $(use_with opengl) $(use_enable !noamazon amazon)"
+
+ kde_src_compile
+}