summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-09-20 11:22:01 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-09-20 11:22:01 +0000
commit22c4e0f29c6a9b5489bc67b2f63517361ceca501 (patch)
treef70d13452831d577618c62a0e26685b0a266d151 /media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild
parentVersion bump. Closes #28103. (diff)
downloadgentoo-2-22c4e0f29c6a9b5489bc67b2f63517361ceca501.tar.gz
gentoo-2-22c4e0f29c6a9b5489bc67b2f63517361ceca501.tar.bz2
gentoo-2-22c4e0f29c6a9b5489bc67b2f63517361ceca501.zip
Version bump. Closes #28103.
Diffstat (limited to 'media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild')
-rw-r--r--media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild b/media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild
new file mode 100644
index 000000000000..b41cad2100c7
--- /dev/null
+++ b/media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-patch-bay/alsa-patch-bay-0.5.2.ebuild,v 1.1 2003/09/20 11:21:57 jje Exp $
+
+DESCRIPTION="Graphical patch bay for the ALSA sequencer API."
+HOMEPAGE="http://pkl.net/~node/alsa-patch-bay.html"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="fltk"
+
+# The package defaults to the gtkmm graphics library.
+# To use fltk instead, do $ USE="fltk" emerge alsa-patch-bay
+# Note: fltk is not an official USE flag, and the dependency on
+# it may go away in the future.
+DEPEND="!fltk? >=dev-cpp/gtkmm-2.0
+ fltk? >=x11-libs/fltk-1.1.2
+ >=media-sound/alsa-driver-0.9.0_rc1
+ >=media-libs/alsa-lib-0.9.0_rc1
+ >=media-sound/alsa-utils-0.9.0_rc1"
+
+SRC_URI="http://pkl.net/~node/software/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+ use fltk || myconf="--disable-fltk"
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall APB_DESKTOP_PREFIX=${D}/usr/share || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}
+
+pkg_preinst() {
+ if [ -e ${D}/usr/bin/jack-patch-bay ]
+ then
+ rm ${D}/usr/bin/jack-patch-bay
+ ln -s alsa-patch-bay ${D}/usr/bin/jack-patch-bay
+ fi
+}