summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-06 20:04:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-06 20:04:13 +0000
commit8bc855345855ee7c92931aa1a49594810d28d1a9 (patch)
tree541c824e0c599c485e95e51dcae367b07f043eca /media-sound/alsa-driver
parentStable on MIPS. (diff)
downloadgentoo-2-8bc855345855ee7c92931aa1a49594810d28d1a9.tar.gz
gentoo-2-8bc855345855ee7c92931aa1a49594810d28d1a9.tar.bz2
gentoo-2-8bc855345855ee7c92931aa1a49594810d28d1a9.zip
Add a check for ISA drivers, improve check for PNP/FW_LOADER drivers, properly check for SND being disabled in kernel.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild45
2 files changed, 29 insertions, 23 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 21a8625c1f49..5c07004e8951 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.241 2006/12/06 17:03:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.242 2006/12/06 20:04:13 flameeyes Exp $
+
+ 06 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ alsa-driver-1.0.14_pre20061130.ebuild:
+ Add a check for ISA drivers, improve check for PNP/FW_LOADER drivers,
+ properly check for SND being disabled in kernel.
06 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-driver-1.0.14_pre20061130.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
index a397d1b5365b..7205ad01a276 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild,v 1.3 2006/12/06 17:03:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild,v 1.4 2006/12/06 20:04:13 flameeyes Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -60,35 +60,36 @@ pkg_setup() {
#
ALSA_CARDS=${ALSA_CARDS:-${IUSE_ALSA_CARDS}}
+ local PNP_DRIVERS="interwave interwave-stb"
+ local PNP_ERROR="Some of the drivers you selected require PnP support in your kernel (${PNP_DRIVERS}). Either enable PnP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ local ISA_DRIVERS="cs4232 msnd-pinnacle cs4231-lib adlib ad1816a ad1848 als100 azt2320
+ cmi8330 cs4231 cs4236 dt019x es968 es1688 es18xx gusclassic gusextreme gusmax
+ interwave interwave-stb opl3sa2 opti92x-ad1848 opti92x-cs4231 opti93x miro sb8
+ sb16 sbawe sb16_csp sgalaxy sscape wavefront"
+ local ISA_ERROR="Some of the drivers you selected require ISA support in your kernel ($(echo $ISA_DRIVERS)). Either enable ISA in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ local FW_DRIVERS="emu10k1"
+ local FW_LOADER_ERROR="Some of the drivers you selected require 'Userspace firmware loading support' in your kernel (${FW_DRIVERS}). Either enable that feature or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
local TMP_ALSA_CARDS
+ local CHECK_PNP
+ local CHECK_ISA
+ local CHECK_FW
for card in ${ALSA_CARDS}; do
- has alsa_cards_${card} ${IUSE} && use alsa_cards_${card} && TMP_ALSA_CARDS="${TMP_ALSA_CARDS} ${card}"
+ if has alsa_cards_${card} ${IUSE} && use alsa_cards_${card}; then
+ TMP_ALSA_CARDS="${TMP_ALSA_CARDS} ${card}"
+ has ${card} ${PNP_DRIVERS} && CHECK_PNP="PNP"
+ has ${card} ${ISA_DRIVERS} && CHECK_ISA="ISA"
+ has ${card} ${FW_DRIVERS} && CHECK_FW="FW_LOADER"
+ fi
done
ALSA_CARDS="${TMP_ALSA_CARDS}"
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
- local FW_DRIVERS="emu10k1"
-
- local CONFIG_CHECK="SOUND"
+ local CONFIG_CHECK="!SND SOUND ${CHECK_PNP} ${CHECK_ISA} ${CHECK_FW}"
local SND_ERROR="ALSA is already compiled into the kernel."
local SOUND_ERROR="Your kernel doesn't have sound support enabled."
local SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- local PNP_ERROR="Some of the drivers you selected require PnP support in your kernel (${PNP_DRIVERS}). Either enable PnP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
- local FW_LOADER_ERROR="Some of the drivers you selected require 'Userspace firmware loading support' in your kernel (${FW_DRIVERS}). Either enable that feature or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- for pnpdriver in ${PNP_DRIVERS}; do
- if use alsa_cards_${pnpdriver}; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- break;
- fi
- done
- for fwdriver in ${FW_DRIVERS}; do
- if use alsa_cards_${fwdriver}; then
- CONFIG_CHECK="${CONFIG_CHECK} FW_LOADER"
- break;
- fi
- done
linux-mod_pkg_setup