summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-05-26 18:44:04 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-05-26 18:44:04 +0000
commitfcd6d373675a8b6ed9bbe3b009d7f5b36057c374 (patch)
tree57dc39c59c9a8d622bcc48d9755971874fb826d6 /media-radio
parentClean up after removing some lastrited packages. (diff)
downloadgentoo-2-fcd6d373675a8b6ed9bbe3b009d7f5b36057c374.tar.gz
gentoo-2-fcd6d373675a8b6ed9bbe3b009d7f5b36057c374.tar.bz2
gentoo-2-fcd6d373675a8b6ed9bbe3b009d7f5b36057c374.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x24083D3E28343508)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xdx/ChangeLog9
-rw-r--r--media-radio/xdx/xdx-2.5.0.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/media-radio/xdx/ChangeLog b/media-radio/xdx/ChangeLog
index 5ec38309a5f9..9175e8877b5c 100644
--- a/media-radio/xdx/ChangeLog
+++ b/media-radio/xdx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/xdx
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xdx/ChangeLog,v 1.31 2014/08/10 21:04:10 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xdx/ChangeLog,v 1.32 2015/05/26 18:44:04 tomjbe Exp $
+
+*xdx-2.5.0 (26 May 2015)
+
+ 26 May 2015; Thomas Beierlein <tomjbe@gentoo.org> +xdx-2.5.0.ebuild:
+ Version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> xdx-2.4.2.ebuild,
xdx-2.4.3.ebuild:
diff --git a/media-radio/xdx/xdx-2.5.0.ebuild b/media-radio/xdx/xdx-2.5.0.ebuild
new file mode 100644
index 000000000000..ebf42a476386
--- /dev/null
+++ b/media-radio/xdx/xdx-2.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xdx/xdx-2.5.0.ebuild,v 1.1 2015/05/26 18:44:04 tomjbe Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="a GTK+ TCP/IP DX-cluster and ON4KST chat client"
+HOMEPAGE="http://sourceforge.net/projects/xdxclusterclient"
+SRC_URI="mirror://sourceforge/xdxclusterclient/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "To use the rig control feature, install media-libs/hamlib"
+ elog "and enable hamlib in the Preferences dialog. (no need for recompile)"
+}