summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-02-07 06:22:12 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-02-07 06:22:12 +0000
commit00b6800d6c7c1c802d868c78c54306f3239fa7ee (patch)
treefcc2c567f99903c39ae88f310fece3e53c853639 /media-radio/xdx/xdx-2.4.3.ebuild
parentImproved ifconfig location fix (diff)
downloadgentoo-2-00b6800d6c7c1c802d868c78c54306f3239fa7ee.tar.gz
gentoo-2-00b6800d6c7c1c802d868c78c54306f3239fa7ee.tar.bz2
gentoo-2-00b6800d6c7c1c802d868c78c54306f3239fa7ee.zip
Version bump. New maintainer. New SRC_URI
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio/xdx/xdx-2.4.3.ebuild')
-rw-r--r--media-radio/xdx/xdx-2.4.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-radio/xdx/xdx-2.4.3.ebuild b/media-radio/xdx/xdx-2.4.3.ebuild
new file mode 100644
index 000000000000..7f3dd9f55bf7
--- /dev/null
+++ b/media-radio/xdx/xdx-2.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xdx/xdx-2.4.3.ebuild,v 1.1 2014/02/07 06:22:12 tomjbe Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="a GTK+ TCP/IP DX-cluster and ON4KST chat client."
+HOMEPAGE="http://sourceforge.net/projects/xdxclusterclient"
+SRC_URI="mirror://sourceforge/xdxclusterclient/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "To use the rig control feature, install media-libs/hamlib"
+ elog "and enable hamlib in the Preferences dialog. (no need for recompile)"
+}