summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-06-04 04:20:49 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-06-04 04:20:49 +0000
commit5c7b814e8d89600a9d8dd00b6012c8aa102d9780 (patch)
treec244feaf3e4699dba3308b01d23ef0ae163cfe7a /media-radio/xdx/xdx-1.2.ebuild
parentStable on mips. (Manifest recommit) (diff)
downloadgentoo-2-5c7b814e8d89600a9d8dd00b6012c8aa102d9780.tar.gz
gentoo-2-5c7b814e8d89600a9d8dd00b6012c8aa102d9780.tar.bz2
gentoo-2-5c7b814e8d89600a9d8dd00b6012c8aa102d9780.zip
New package submitted by Robb. Fixes #52307
Diffstat (limited to 'media-radio/xdx/xdx-1.2.ebuild')
-rw-r--r--media-radio/xdx/xdx-1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-radio/xdx/xdx-1.2.ebuild b/media-radio/xdx/xdx-1.2.ebuild
new file mode 100644
index 000000000000..7674fa7ba155
--- /dev/null
+++ b/media-radio/xdx/xdx-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xdx/xdx-1.2.ebuild,v 1.1 2004/06/04 04:20:49 rphillips Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK2 DX-cluster client"
+HOMEPAGE="http://www.qsl.net/pg4i/linux/xdx.html"
+SRC_URI="http://www.qsl.net/pg4i/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ virtual/x11
+ >=x11-libs/gtk+-2.2.4-r1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall
+ dodoc README AUTHORS ChangeLog
+ doman xdx.1
+ make_desktop_entry xdx Xdx /usr/share/xdx/pixmaps/xdx.xpm HamRadio
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use the rig control feature of xdx, install"
+ einfo "app-ham/hamlib and enable hamlib in the"
+ einfo "Preferences dialog."
+ echo
+}