summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 18:39:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 18:39:07 +0000
commit93cb8a3f86b642a1fc710b6d959ed8e535e8b6b6 (patch)
tree0dcdfc632645fa8985b645ec8455c988a8e36f81 /media-radio/KochMorse/KochMorse-0.99.6.ebuild
parentppc/ppc64 stable wrt #346981 (diff)
downloadgentoo-2-93cb8a3f86b642a1fc710b6d959ed8e535e8b6b6.tar.gz
gentoo-2-93cb8a3f86b642a1fc710b6d959ed8e535e8b6b6.tar.bz2
gentoo-2-93cb8a3f86b642a1fc710b6d959ed8e535e8b6b6.zip
Use Python 2.
(Portage version: 2.2.0_alpha26_p15/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/KochMorse/KochMorse-0.99.6.ebuild')
-rw-r--r--media-radio/KochMorse/KochMorse-0.99.6.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/media-radio/KochMorse/KochMorse-0.99.6.ebuild b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
index 3cb6d35ac6de..9b6d9f449bcf 100644
--- a/media-radio/KochMorse/KochMorse-0.99.6.ebuild
+++ b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/KochMorse-0.99.6.ebuild,v 1.3 2010/10/05 20:48:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/KochMorse-0.99.6.ebuild,v 1.4 2011/03/11 18:39:07 arfrever Exp $
-EAPI=2
+EAPI="3"
+PYTHON_DEPEND="2"
-PYTHON_DEPEND="*"
-
-inherit distutils python
+inherit distutils
DESCRIPTION="Morse-tutor for Linux using the Koch-method"
HOMEPAGE="http://KochMorse.googlecode.com/"
@@ -17,5 +16,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="dev-python/pyalsaaudio
+DEPEND="dev-python/pyalsaaudio
dev-python/pygtk"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}