summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-23 07:58:04 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-23 07:58:04 +0000
commitb5ae06937bb0f8bad8e87f3a7a51f09c2379f3cb (patch)
tree3861a3dd85d1bab967dfb733fd98430f3cbbfbf1 /media-plugins
parentBump, fixes a memory leak. (diff)
downloadgentoo-2-b5ae06937bb0f8bad8e87f3a7a51f09c2379f3cb.tar.gz
gentoo-2-b5ae06937bb0f8bad8e87f3a7a51f09c2379f3cb.tar.bz2
gentoo-2-b5ae06937bb0f8bad8e87f3a7a51f09c2379f3cb.zip
Bump, improves error handling, fixes various bugs. Fix build failure with recent linux-headers (bug #437012, thanks to Jason Lamb et al.)
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-v4l2/ChangeLog12
-rw-r--r--media-plugins/gst-plugins-v4l2/files/gst-plugins-v4l2-0.10.31-linux-headers-3.6.patch38
-rw-r--r--media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.31.ebuild26
3 files changed, 74 insertions, 2 deletions
diff --git a/media-plugins/gst-plugins-v4l2/ChangeLog b/media-plugins/gst-plugins-v4l2/ChangeLog
index 1248dcbb8d89..774e24ad1bdc 100644
--- a/media-plugins/gst-plugins-v4l2/ChangeLog
+++ b/media-plugins/gst-plugins-v4l2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/gst-plugins-v4l2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/ChangeLog,v 1.90 2011/10/15 18:35:18 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/ChangeLog,v 1.91 2012/10/23 07:58:04 tetromino Exp $
+
+*gst-plugins-v4l2-0.10.31 (23 Oct 2012)
+
+ 23 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gst-plugins-v4l2-0.10.31.ebuild,
+ +files/gst-plugins-v4l2-0.10.31-linux-headers-3.6.patch:
+ Bump, improves error handling, fixes various bugs. Fix build failure with
+ recent linux-headers (bug #437012, thanks to Jason Lamb et al.)
15 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-v4l2-0.10.30.ebuild:
diff --git a/media-plugins/gst-plugins-v4l2/files/gst-plugins-v4l2-0.10.31-linux-headers-3.6.patch b/media-plugins/gst-plugins-v4l2/files/gst-plugins-v4l2-0.10.31-linux-headers-3.6.patch
new file mode 100644
index 000000000000..919b19b7dc4b
--- /dev/null
+++ b/media-plugins/gst-plugins-v4l2/files/gst-plugins-v4l2-0.10.31-linux-headers-3.6.patch
@@ -0,0 +1,38 @@
+From 968a3dac9959c2a6ae4ff619535db15b37446ce4 Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Thu, 9 Aug 2012 08:35:23 +0100
+Subject: [PATCH] v4l2: fix build with recent kernels, the v4l2_buffer input
+ field was removed
+
+This was unused apparently and removed in the kernel in commit:
+
+ From 2b719d7baf490e24ce7d817c6337b7c87fda84c1 Mon Sep 17 00:00:00 2001
+ From: Sakari Ailus <sakari.ailus@iki.fi>
+ Date: Wed, 2 May 2012 09:40:03 -0300
+ Subject: [PATCH] [media] v4l: drop v4l2_buffer.input and V4L2_BUF_FLAG_INPUT
+
+ Remove input field in struct v4l2_buffer and flag V4L2_BUF_FLAG_INPUT which
+ tells the former is valid. The flag is used by no driver currently.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=681491
+
+[Alexandre Rostovtsev <tetromino@gentoo.org>: backport to 0.10.31]
+---
+ sys/v4l2/gstv4l2bufferpool.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/sys/v4l2/gstv4l2bufferpool.c b/sys/v4l2/gstv4l2bufferpool.c
+index b81c6a4..51cc0ce 100644
+--- a/sys/v4l2/gstv4l2bufferpool.c
++++ b/sys/v4l2/gstv4l2bufferpool.c
+@@ -181,7 +181,6 @@ gst_v4l2_buffer_new (GstV4l2BufferPool * pool, guint index, GstCaps * caps)
+ GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
+ ret->vbuffer.m.offset);
+ GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
+- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
+
+ data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
+ PROT_READ | PROT_WRITE, MAP_SHARED, pool->video_fd,
+--
+1.7.12.3
+
diff --git a/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.31.ebuild b/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.31.ebuild
new file mode 100644
index 000000000000..1ef9c6af2b20
--- /dev/null
+++ b/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.31.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.31.ebuild,v 1.1 2012/10/23 07:58:04 tetromino Exp $
+
+EAPI=4
+
+inherit eutils gst-plugins-good
+
+DESCRIPION="plugin to allow capture from video4linux2 devices"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.36
+ media-libs/libv4l"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+GST_PLUGINS_BUILD="gst_v4l2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.10.31-linux-headers-3.6.patch" #437012
+}
+
+src_configure() {
+ gst-plugins-good_src_configure --with-libv4l2
+}