summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-05-04 11:20:44 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-05-04 11:20:44 +0000
commitb1f3f99d0d5ca5ed602fc7d3e54099b04c8e5f54 (patch)
treee8b0c874d602eded0be8118735bf808b7303c96b /media-plugins
parentRestore 2.6.6, bug 176975 (diff)
downloadgentoo-2-b1f3f99d0d5ca5ed602fc7d3e54099b04c8e5f54.tar.gz
gentoo-2-b1f3f99d0d5ca5ed602fc7d3e54099b04c8e5f54.tar.bz2
gentoo-2-b1f3f99d0d5ca5ed602fc7d3e54099b04c8e5f54.zip
Version bump. Closes bug #174728.
(Portage version: 2.1.2.5)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog8
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.3.4.ebuild111
-rw-r--r--media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.43
3 files changed, 121 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index a430236d2562..26ef5b90e0fd 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.53 2007/04/15 20:54:46 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.54 2007/05/04 11:20:44 chainsaw Exp $
+
+*audacious-plugins-1.3.4 (04 May 2007)
+
+ 04 May 2007; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-plugins-1.3.4.ebuild:
+ Version bump. Closes bug #174728.
15 Apr 2007; Peter Weller <welp@gentoo.org>
audacious-plugins-1.3.3.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.3.4.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.3.4.ebuild
new file mode 100644
index 000000000000..7f237499478a
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.3.4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.3.4.ebuild,v 1.1 2007/05/04 11:20:44 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://static.audacious-media-player.org/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac adplug alsa arts chardet esd flac jack lirc mad modplug musepack nls opengl oss sid sndfile timidity tta vorbis wavpack wma pulseaudio"
+
+RDEPEND="app-arch/unzip
+ dev-libs/libxml2
+ media-libs/libsamplerate
+ net-misc/curl
+ >=media-sound/audacious-1.3.2
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=media-libs/libsdl-1.2.5
+ media-libs/taglib
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ mad? ( media-libs/libmad )
+ musepack? ( media-libs/libmpcdec )
+ opengl? ( =media-libs/libprojectm-0.99* )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ tta? ( media-libs/libid3tag )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ wavpack? ( >=media-sound/wavpack-4.31 )
+ wma? ( >=media-libs/libmms-0.3 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0
+ !media-plugins/audacious-docklet
+ !=media-plugins/audacious-plugins-ugly-1.2.0"
+
+mp3_warning() {
+ if ! useq mad ; then
+ echo
+ ewarn "MP3 support is optional, you may want to enable the mad USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ --enable-paranormal \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mad mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable chardet) \
+ $(use_enable wavpack) \
+ $(use_enable tta) \
+ $(use_enable opengl projectm) \
+ $(use_enable adplug) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+ elog "Note that you need to recompile *all* third-party plugins to use Audacious 1.3 builds."
+ elog "To clarify, that means all plugins *not* contained in this ebuild. Failure to do so may cause "
+ elog "the player to crash. Rebuild, and if that fails, unmerge, any third-party plugins before you "
+ elog "report a bug."
+}
diff --git a/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.4 b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.4
new file mode 100644
index 000000000000..063dad947167
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.4
@@ -0,0 +1,3 @@
+MD5 417ffe1cae7081b0dec404b659a6d67e audacious-plugins-1.3.4.tgz 2977560
+RMD160 66c5eb81346b0d1badfa19e5557bff7f6d4c2216 audacious-plugins-1.3.4.tgz 2977560
+SHA256 44534b9f1e03649322a3a9ff8bba99cb5790a736e81241d9285e40957aecb324 audacious-plugins-1.3.4.tgz 2977560