summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 18:01:17 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 18:01:17 +0000
commit3e3cc07f421a68bca52fafa35c251a7810883252 (patch)
tree7b22768699047f21376684a7a4d96290e58c11b0 /media-plugins
parentInitial version. (diff)
downloadgentoo-2-3e3cc07f421a68bca52fafa35c251a7810883252.tar.gz
gentoo-2-3e3cc07f421a68bca52fafa35c251a7810883252.tar.bz2
gentoo-2-3e3cc07f421a68bca52fafa35c251a7810883252.zip
Bump version to 0.11.
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythgallery/ChangeLog7
-rw-r--r--media-plugins/mythgallery/Manifest4
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.111
-rw-r--r--media-plugins/mythgallery/mythgallery-0.11.ebuild61
4 files changed, 71 insertions, 2 deletions
diff --git a/media-plugins/mythgallery/ChangeLog b/media-plugins/mythgallery/ChangeLog
index 8c20337c5bd5..e575da7d3ac8 100644
--- a/media-plugins/mythgallery/ChangeLog
+++ b/media-plugins/mythgallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgallery
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.3 2003/08/08 05:16:47 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.4 2003/08/18 18:00:55 max Exp $
+
+*mythgallery-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythgallery-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythgallery-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index 09987e36816e..f9edb2fd4ad6 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -1,3 +1,5 @@
+MD5 d108a1af804667dffc1c7872465f6df2 mythgallery-0.11.ebuild 1692
MD5 52bfb7cc60fe0cd218a9376e634b724d mythgallery-0.10.ebuild 1725
-MD5 f656bb8c38bbd3bbebe1d35698c02a99 ChangeLog 1346
+MD5 cdef693457802973ff52b7390f068e42 ChangeLog 1505
MD5 08ad7857fea9bfc28178d4e14aa3ae10 files/digest-mythgallery-0.10 67
+MD5 f367099e5641367ed71e682eed2243e5 files/digest-mythgallery-0.11 67
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.11 b/media-plugins/mythgallery/files/digest-mythgallery-0.11
new file mode 100644
index 000000000000..26f97524e9ef
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.11
@@ -0,0 +1 @@
+MD5 03c4466e71b98ba1535210a3781ba952 mythgallery-0.11.tar.bz2 9981
diff --git a/media-plugins/mythgallery/mythgallery-0.11.ebuild b/media-plugins/mythgallery/mythgallery-0.11.ebuild
new file mode 100644
index 000000000000..e3d56c39dd83
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.11.ebuild,v 1.1 2003/08/18 18:00:55 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins database/*.sql
+
+ dodoc COPYING README UPGRADING
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGallery,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/gallery.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/gallery.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}