summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-10-31 03:09:03 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-10-31 03:09:03 +0000
commitc62051e4bdf8af8936ca9cdd2614ac10cb8e056c (patch)
treefeac9a78f348d643f73020d703880e4b60a7375f /media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild
parent2.0.53_rc7 release (diff)
downloadgentoo-2-c62051e4bdf8af8936ca9cdd2614ac10cb8e056c.tar.gz
gentoo-2-c62051e4bdf8af8936ca9cdd2614ac10cb8e056c.tar.bz2
gentoo-2-c62051e4bdf8af8936ca9cdd2614ac10cb8e056c.zip
Added Debian patches to fix a few bugs including bug #103435.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild')
-rw-r--r--media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild b/media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild
new file mode 100644
index 000000000000..281bbf42337e
--- /dev/null
+++ b/media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-infopipe/xmms-infopipe-1.3-r1.ebuild,v 1.1 2005/10/31 03:09:03 metalgod Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Publish information about currently playing song in xmms to a temp file"
+SRC_URI="http://www.beastwithin.org/users/wwwwolf/code/xmms/${P}.tar.gz"
+HOMEPAGE="http://www.beastwithin.org/users/wwwwolf/code/xmms/infopipe.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="media-sound/xmms"
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix bad configure which breaks newer portage.
+ cd ${S}
+ mv configure configure.old
+ cat - configure.old > configure << EOF
+#!/bin/sh
+EOF
+
+ chmod 755 configure
+
+ epatch ${FILESDIR}/${PN}-tweaks.patch
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}