summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-29 04:03:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-29 04:03:31 +0000
commit526453448e155c2e451ddd79c9d50e2370a47b92 (patch)
treed6d1104f20e5265903aa818aaf98b21a00d3bfa6 /media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild
parentHOMEPAGE fix (diff)
downloadgentoo-2-526453448e155c2e451ddd79c9d50e2370a47b92.tar.gz
gentoo-2-526453448e155c2e451ddd79c9d50e2370a47b92.tar.bz2
gentoo-2-526453448e155c2e451ddd79c9d50e2370a47b92.zip
Version bump
Diffstat (limited to 'media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild')
-rw-r--r--media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild b/media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild
new file mode 100644
index 000000000000..7ff44919e88d
--- /dev/null
+++ b/media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-dspectral/xmms-dspectral-1.2.1.ebuild,v 1.1 2003/03/29 04:03:31 seemant Exp $
+
+MY_P=${PN/xmms-/}-v${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dual spectral analyzer visualization plugin for xmms"
+HOMEPAGE="http://www.shell.linux.se/bm/index.php?page=xmmsplugin"
+SRC_URI="http://www.shell.linux.se/bm/f/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ media-sound/xmms"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ # patch in DESTDIR support
+ epatch ${FILESDIR}/${MY_P}-destdir.patch
+}
+
+src_compile() {
+ # There is no configure script, but the
+ # Makefile does things (mostly) correctly.
+ make clean || die
+ emake OPT="$CFLAGS" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README COPYING Changes
+}