summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-16 12:21:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-16 12:21:31 +0000
commit61cd21c7049895f8e497be4e2cee4d6bd413f363 (patch)
tree7b3de7b7eed09b212ad3b8b0f9fa2d4368970164 /media-plugins/vdr-graphtft
parentfix build with ffmpeg >= 0.6 (diff)
downloadgentoo-2-61cd21c7049895f8e497be4e2cee4d6bd413f363.tar.gz
gentoo-2-61cd21c7049895f8e497be4e2cee4d6bd413f363.tar.bz2
gentoo-2-61cd21c7049895f8e497be4e2cee4d6bd413f363.zip
fix build with ffmpeg >= 0.6
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/vdr-graphtft')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog6
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 54682d86143b..cd5b485308e3 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.22 2010/04/03 10:07:49 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.23 2010/06/16 12:21:31 aballier Exp $
+
+ 16 Jun 2010; Alexis Ballier <aballier@gentoo.org>
+ vdr-graphtft-0.3.2.24.ebuild:
+ fix build with ffmpeg >= 0.6
03 Apr 2010; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-graphtft-0.3.2.24.ebuild:
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
index b8c656f20fb4..ebae64eadba8 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.4 2010/04/03 10:07:49 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.5 2010/06/16 12:21:31 aballier Exp $
EAPI="2"
-inherit eutils vdr-plugin
+inherit eutils vdr-plugin flag-o-matic
#MY_P="${PN}-${PV/_rc/-rc}"
#S="${WORKDIR}/graphtft-${PV/_rc/-rc}"
@@ -81,6 +81,8 @@ src_prepare() {
sed -i "${S}"/imlibrenderer/fbrenderer/fbrenderer.c \
-i "${S}"/imlibrenderer/dvbrenderer/mpeg2encoder.c \
-e "s:libavutil/avcodec.h:libavcodec/avcodec.h:"
+ # UINT64_C is needed by ffmpeg headers
+ append-flags -D__STDC_CONSTANT_MACROS
}
src_compile() {