summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-01-04 05:59:16 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-01-04 05:59:16 +0000
commit390bf1cc74e044b6f3baec8517a439316bdc0d42 (patch)
treef5ff36a3de8f8466aac6b62a95d8f7114876a4d3 /media-plugins/mythvideo
parentversion bump. fixes some grabbers (diff)
downloadgentoo-2-390bf1cc74e044b6f3baec8517a439316bdc0d42.tar.gz
gentoo-2-390bf1cc74e044b6f3baec8517a439316bdc0d42.tar.bz2
gentoo-2-390bf1cc74e044b6f3baec8517a439316bdc0d42.zip
version bump. fix DVD drive handling
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog10
-rw-r--r--media-plugins/mythvideo/mythvideo-0.22_p22991.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index 78435f687c85..591a8fe40428 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythvideo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.83 2009/11/22 05:57:25 cardoe Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.84 2010/01/04 05:59:16 cardoe Exp $
+
+*mythvideo-0.22_p22991 (04 Jan 2010)
+
+ 04 Jan 2010; Doug Goldstein <cardoe@gentoo.org>
+ +mythvideo-0.22_p22991.ebuild:
+ version bump. fix DVD drive handling
*mythvideo-0.22_p22864-r1 (22 Nov 2009)
diff --git a/media-plugins/mythvideo/mythvideo-0.22_p22991.ebuild b/media-plugins/mythvideo/mythvideo-0.22_p22991.ebuild
new file mode 100644
index 000000000000..2555994570c0
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.22_p22991.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.22_p22991.ebuild,v 1.1 2010/01/04 05:59:16 cardoe Exp $
+
+EAPI=2
+
+inherit qt4 mythtv-plugins
+
+DESCRIPTION="Video player module for MythTV."
+IUSE="+jamu"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/URI
+ dev-perl/XML-Simple
+ sys-apps/eject
+ jamu? ( >=dev-python/imdbpy-3.8
+ >=dev-python/mysql-python-1.2.2
+ media-tv/mythtv[python] )"
+DEPEND=""
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init.d mtd
+
+ # correct permissions so MythVideo is actually usable
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.py
+
+ # setup JAMU cron jobs
+ if use jamu; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/mythvideo.daily" mythvideo || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/mythvideo.hourly" mythvideo || die
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/mythvideo.weekly" mythvideo || die
+ insinto /home/mythtv/.mythtv/
+ newins mythvideo/scripts/jamu-example.conf jamu.conf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "MythVideo can use any media player to playback files if you"
+ elog "are *NOT* using Storage Groups. If you are using Storage"
+ elog "Groups, you *MUST* use the Internal player."
+ elog
+ elog "Otherwise, you can install mplayer, xine or any other video"
+ elog "player and use that instead by configuring the player to use."
+ elog "The default is 'Internal'."
+}