summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-14 01:29:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-14 01:29:41 +0000
commitaf6fa8359fec460dc6204563e83238760d2b38fe (patch)
tree8113dada1d23c903c83c1e36c5ecc10c0d2c1e17 /media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild
parent inital ebuild thanks to request from Michael R. Lawrence in bug #158474 (diff)
downloadgentoo-2-af6fa8359fec460dc6204563e83238760d2b38fe.tar.gz
gentoo-2-af6fa8359fec460dc6204563e83238760d2b38fe.tar.bz2
gentoo-2-af6fa8359fec460dc6204563e83238760d2b38fe.zip
require media-video/mjpegtools to be built with png support. mark latest version as stable since previous versions are for sure broken. remove old versions
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild')
-rw-r--r--media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild b/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild
index dd3f25abe151..7157b8da967c 100644
--- a/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild
+++ b/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild,v 1.1 2007/02/22 16:16:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mytharchive/mytharchive-0.20_p12824.ebuild,v 1.2 2007/04/14 01:29:41 cardoe Exp $
inherit mythtv-plugins
@@ -8,7 +8,7 @@ SRC_URI="${SRC_URI}
http://dev.gentoo.org/~cardoe/files/mythtv/mytharchive-newfiles-11564.tar.bz2"
DESCRIPTION="Allows for archiving your videos to DVD."
IUSE=""
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
RDEPEND=">=dev-lang/python-2.3.5
dev-python/mysql-python
@@ -21,6 +21,16 @@ RDEPEND=">=dev-lang/python-2.3.5
media-video/transcode"
DEPEND="${RDEPEND}"
+pkg_setup()
+{
+ mythtv-plugins_pkg_setup
+
+ if ! built_with_use media-video/mjpegtools png; then
+ eerror "You MUST build media-video/mjpegtools with the png USE flag"
+ die "You MUST build media-video/mjpegtools with the png USE flag"
+ fi
+}
+
src_unpack()
{
mythtv-plugins_src_unpack