summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-21 08:02:38 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-21 08:02:38 +0000
commit0fc7b13f056da585056c0b1123688717fa3d27f9 (patch)
treef979723a992a76e5c9d33320f584e9825b6081cd /media-plugins/gst-plugins-xvideo
parentVersion bump with some bugfixes. (diff)
downloadgentoo-2-0fc7b13f056da585056c0b1123688717fa3d27f9.tar.gz
gentoo-2-0fc7b13f056da585056c0b1123688717fa3d27f9.tar.bz2
gentoo-2-0fc7b13f056da585056c0b1123688717fa3d27f9.zip
Version bump with some bugfixes.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/gst-plugins-xvideo')
-rw-r--r--media-plugins/gst-plugins-xvideo/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild9
-rw-r--r--media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36.ebuild31
3 files changed, 45 insertions, 3 deletions
diff --git a/media-plugins/gst-plugins-xvideo/ChangeLog b/media-plugins/gst-plugins-xvideo/ChangeLog
index 628b8630949e..40259722fa79 100644
--- a/media-plugins/gst-plugins-xvideo/ChangeLog
+++ b/media-plugins/gst-plugins-xvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-xvideo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.186 2012/10/19 13:25:45 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.187 2012/10/21 08:02:38 tetromino Exp $
+
+*gst-plugins-xvideo-0.10.36 (21 Oct 2012)
+
+ 21 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gst-plugins-xvideo-0.10.35.ebuild, +gst-plugins-xvideo-0.10.36.ebuild:
+ Version bump with some bugfixes.
*gst-plugins-xvideo-0.10.35-r1 (19 Oct 2012)
diff --git a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild
index bd15f8221afd..d9a923098c13 100644
--- a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild
+++ b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild,v 1.8 2012/05/17 15:26:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild,v 1.9 2012/10/21 08:02:38 tetromino Exp $
inherit gst-plugins-base
@@ -8,7 +8,12 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x8
IUSE=""
RDEPEND="x11-libs/libXv
- x11-libs/libXext"
+ x11-libs/libXext
+
+ x11-libs/libSM
+ x11-libs/libICE"
+# libSM and libICE are not used, but the build system links to them anyway
+# Fixed in >=0.10.35-r1
DEPEND="${RDEPEND}
x11-proto/videoproto
x11-proto/xproto
diff --git a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36.ebuild b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36.ebuild
new file mode 100644
index 000000000000..cfef8228c745
--- /dev/null
+++ b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36.ebuild,v 1.1 2012/10/21 08:02:38 tetromino Exp $
+
+EAPI=4
+
+inherit gst-plugins-base
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libXv
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/videoproto
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+# xshm is a compile time option of xvideo
+# x is needed to build any X plugins, but we build/install only xv anyway
+GST_PLUGINS_BUILD="x xvideo xshm"
+GST_PLUGINS_BUILD_DIR="xvimage"
+
+src_prepare() {
+ gst-plugins-base_src_prepare
+
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+}