summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-16 07:52:20 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-16 07:52:20 +0000
commit84a16ef9b010cb943d709ec6930558b918a8ee05 (patch)
treee7d62e267fda7f72baced65469e2000e39727ae4 /media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild
parentFix spelling error in ChangeLog. (diff)
downloadgentoo-2-84a16ef9b010cb943d709ec6930558b918a8ee05.tar.gz
gentoo-2-84a16ef9b010cb943d709ec6930558b918a8ee05.tar.bz2
gentoo-2-84a16ef9b010cb943d709ec6930558b918a8ee05.zip
Fix build system to split LDFLAGS and LIBS so the --as-needed linker option is fully respected for all linked libs.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild')
-rw-r--r--media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild b/media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild
new file mode 100644
index 000000000000..d1b0bb8e4c39
--- /dev/null
+++ b/media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.5.9.2-r1.ebuild,v 1.1 2014/06/16 07:52:20 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="G'MIC GIMP plugin"
+HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml"
+SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-gfx/gimp-2.4.0
+ media-libs/libpng:0=
+ sci-libs/fftw:3.0[threads]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/gmic-${PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/gmic-${PV}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= gimp
+}
+
+src_install() {
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe gmic_gimp
+ dodoc ../README
+}
+
+pkg_postinst() {
+ elog "The G'MIC plugin is accessible from the menu:"
+ elog "Filters -> G'MIC"
+}