summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-24 10:47:39 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-24 10:47:39 +0000
commitb982e878b9a9dc47d70265140f35a0a3de4c5b5f (patch)
treefea4d2809ccc64a201dcc71c9af76a9d99cef7dd /media-libs
parentUpdate for systemd wrt bug #491744 (diff)
downloadgentoo-2-b982e878b9a9dc47d70265140f35a0a3de4c5b5f.tar.gz
gentoo-2-b982e878b9a9dc47d70265140f35a0a3de4c5b5f.tar.bz2
gentoo-2-b982e878b9a9dc47d70265140f35a0a3de4c5b5f.zip
media-libs/chromaprint: Version BUmp and drop old (Changelog says: Fixed
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/chromaprint/ChangeLog8
-rw-r--r--media-libs/chromaprint/chromaprint-1.1.ebuild (renamed from media-libs/chromaprint/chromaprint-1.0.ebuild)16
-rw-r--r--media-libs/chromaprint/files/chromaprint-1.1-gtest.patch104
-rw-r--r--media-libs/chromaprint/metadata.xml2
4 files changed, 122 insertions, 8 deletions
diff --git a/media-libs/chromaprint/ChangeLog b/media-libs/chromaprint/ChangeLog
index 0345e3e7327a..e181c63e61e7 100644
--- a/media-libs/chromaprint/ChangeLog
+++ b/media-libs/chromaprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/chromaprint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.11 2013/11/17 14:20:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.12 2013/11/24 10:47:39 jlec Exp $
+
+*chromaprint-1.1 (24 Nov 2013)
+
+ 24 Nov 2013; Justin Lecher <jlec@gentoo.org> -chromaprint-1.0.ebuild,
+ +chromaprint-1.1.ebuild, +files/chromaprint-1.1-gtest.patch, metadata.xml:
+ Version BUmp and drop old (Changelog says: Fixed
17 Nov 2013; Alexis Ballier <aballier@gentoo.org> chromaprint-1.0.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/chromaprint/chromaprint-1.0.ebuild b/media-libs/chromaprint/chromaprint-1.1.ebuild
index 359d65464a60..c57d0b8c1e93 100644
--- a/media-libs/chromaprint/chromaprint-1.0.ebuild
+++ b/media-libs/chromaprint/chromaprint-1.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-1.0.ebuild,v 1.2 2013/11/17 14:20:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-1.1.ebuild,v 1.1 2013/11/24 10:47:39 jlec Exp $
EAPI=5
+
inherit cmake-utils
DESCRIPTION="A client-side library that implements a custom algorithm for extracting fingerprints"
@@ -15,7 +16,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd"
IUSE="test tools"
# note: use ffmpeg instead of fftw because it's recommended and required for tools
-RDEPEND=">=virtual/ffmpeg-0.10
+RDEPEND="
+ >=virtual/ffmpeg-0.10
tools? ( >=media-libs/taglib-1.6 )"
DEPEND="${RDEPEND}
test? (
@@ -26,8 +28,10 @@ DEPEND="${RDEPEND}
DOCS="NEWS.txt README.txt"
-PATCHES=( "${FILESDIR}/${PN}-0.7-ffmpeg.patch"
- "${FILESDIR}/${P}-libav9.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7-ffmpeg.patch
+ "${FILESDIR}"/${P}-gtest.patch
+)
src_configure() {
local mycmakeargs=(
@@ -40,11 +44,11 @@ src_configure() {
}
src_test() {
- cd "${CMAKE_BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
emake check
}
src_install() {
cmake-utils_src_install
- use tools && dobin "${CMAKE_BUILD_DIR}"/tools/fpcollect
+ use tools && dobin "${BUILD_DIR}"/tools/fpcollect
}
diff --git a/media-libs/chromaprint/files/chromaprint-1.1-gtest.patch b/media-libs/chromaprint/files/chromaprint-1.1-gtest.patch
new file mode 100644
index 000000000000..8305ae7c1af0
--- /dev/null
+++ b/media-libs/chromaprint/files/chromaprint-1.1-gtest.patch
@@ -0,0 +1,104 @@
+ cmake/modules/FindGTest.cmake | 82 -------------------------------------------
+ tests/CMakeLists.txt | 1 -
+ 2 files changed, 83 deletions(-)
+
+diff --git a/cmake/modules/FindGTest.cmake b/cmake/modules/FindGTest.cmake
+deleted file mode 100644
+index 21dc2f5..0000000
+--- a/cmake/modules/FindGTest.cmake
++++ /dev/null
+@@ -1,82 +0,0 @@
+-# Locate the Google C++ Testing Framework source directory.
+-#
+-# Defines the following variables:
+-#
+-# GTEST_FOUND - Found the Google Testing framework sources
+-# GTEST_INCLUDE_DIRS - Include directories
+-# GTEST_SOURCE_DIR - Source code directory
+-# GTEST_LIBRARIES - libgtest
+-# GTEST_MAIN_LIBRARIES - libgtest-main
+-# GTEST_BOTH_LIBRARIES - libgtest & libgtest-main
+-#
+-# Accepts the following variables as input:
+-#
+-# GTEST_ROOT - (as CMake or environment variable)
+-# The root directory of the gtest install prefix
+-#
+-# Example usage:
+-#
+-# find_package(GTest REQUIRED)
+-# include_directories(${GTEST_INCLUDE_DIRS})
+-# add_subdirectory(${GTEST_SOURCE_DIR}
+-# ${CMAKE_CURRENT_BINARY_DIR}/gtest_build)
+-#
+-# add_executable(foo foo.cc)
+-# target_link_libraries(foo ${GTEST_BOTH_LIBRARIES})
+-#
+-# enable_testing(true)
+-# add_test(AllTestsInFoo foo)
+-#
+-# =========================================================
+-#
+-# Copyright (C) 2012 Lukas Lalinsky <lalinsky@gmail.com>
+-#
+-# Redistribution and use in source and binary forms, with or without
+-# modification, are permitted provided that the following conditions are
+-# met:
+-#
+-# * Redistributions of source code must retain the above copyright notice,
+-# this list of conditions and the following disclaimer.
+-#
+-# * Redistributions in binary form must reproduce the above copyright notice,
+-# this list of conditions and the following disclaimer in the documentation
+-# and/or other materials provided with the distribution.
+-#
+-# * The names of Kitware, Inc., the Insight Consortium, or the names of
+-# any consortium members, or of any contributors, may not be used to
+-# endorse or promote products derived from this software without
+-# specific prior written permission.
+-#
+-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS ``AS IS''
+-# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+-# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
+-# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+-# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+-# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+-# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+-
+-
+-find_path(GTEST_SOURCE_DIR
+- NAMES src/gtest-all.cc CMakeLists.txt
+- HINTS $ENV{GTEST_ROOT} ${GTEST_ROOT} /usr/src/gtest
+-)
+-mark_as_advanced(GTEST_SOURCE_DIR)
+-
+-find_path(GTEST_INCLUDE_DIR
+- NAMES gtest/gtest.h
+- HINTS $ENV{GTEST_ROOT}/include ${GTEST_ROOT}/include
+-)
+-mark_as_advanced(GTEST_INCLUDE_DIR)
+-
+-include(FindPackageHandleStandardArgs)
+-find_package_handle_standard_args(GTest DEFAULT_MSG GTEST_SOURCE_DIR GTEST_INCLUDE_DIR)
+-
+-if(GTEST_FOUND)
+- set(GTEST_INCLUDE_DIRS ${GTEST_INCLUDE_DIR})
+- set(GTEST_LIBRARIES gtest)
+- set(GTEST_MAIN_LIBRARIES gtest_main)
+- set(GTEST_BOTH_LIBRARIES ${GTEST_LIBRARIES} ${GTEST_MAIN_LIBRARIES})
+-endif()
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 791cd96..9115391 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -3,7 +3,6 @@ include_directories(
+ ${Boost_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../src
+ )
+-add_subdirectory(${GTEST_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR}/gtest_build)
+
+ set(tests_SOURCES
+ main.cpp
diff --git a/media-libs/chromaprint/metadata.xml b/media-libs/chromaprint/metadata.xml
index f13b90f3d998..4cd6b6d902a3 100644
--- a/media-libs/chromaprint/metadata.xml
+++ b/media-libs/chromaprint/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>sound</herd>
<use>
- <flag name='tools'>Build and install fpcalc and fpcollect tools</flag>
+ <flag name="tools">Build and install fpcalc and fpcollect tools</flag>
</use>
</pkgmetadata>