summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 04:05:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 04:05:52 +0000
commit8f4ef7fc54953e8005aab3c9b75bb4eb12b2347f (patch)
treed32b6b9ca6efecedc9e505ca22dc67f3d253349b /media-libs
parentAdd pulseaudio useflag for libao (going to commit soon). (diff)
downloadgentoo-2-8f4ef7fc54953e8005aab3c9b75bb4eb12b2347f.tar.gz
gentoo-2-8f4ef7fc54953e8005aab3c9b75bb4eb12b2347f.tar.bz2
gentoo-2-8f4ef7fc54953e8005aab3c9b75bb4eb12b2347f.zip
Add new revision, with a patch to fix buffer_time parameter on alsa09 driver, thanks to Heikki Orsila in bug #119967, with a doc useflag to install the API documentation, thanks to Nguyen Thai Ngoc Duy (pclouds) in bug #138560, and a pulseaudio useflag to bring in the libao-pulse plugin.
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libao/ChangeLog10
-rw-r--r--media-libs/libao/files/digest-libao-0.8.6-r36
-rw-r--r--media-libs/libao/libao-0.8.6-r3.ebuild59
3 files changed, 74 insertions, 1 deletions
diff --git a/media-libs/libao/ChangeLog b/media-libs/libao/ChangeLog
index 4e2c96868c81..25280f1129b8 100644
--- a/media-libs/libao/ChangeLog
+++ b/media-libs/libao/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libao
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/ChangeLog,v 1.57 2006/09/28 12:35:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/ChangeLog,v 1.58 2006/10/02 04:05:52 flameeyes Exp $
+
+*libao-0.8.6-r3 (02 Oct 2006)
+
+ 02 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +libao-0.8.6-r3.ebuild:
+ Add new revision, with a patch to fix buffer_time parameter on alsa09
+ driver, thanks to Heikki Orsila in bug #119967, with a doc useflag to
+ install the API documentation, thanks to Nguyen Thai Ngoc Duy (pclouds) in
+ bug #138560, and a pulseaudio useflag to bring in the libao-pulse plugin.
28 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Re-absorb into sound herd entirely, as Spider is being away for a while now.
diff --git a/media-libs/libao/files/digest-libao-0.8.6-r3 b/media-libs/libao/files/digest-libao-0.8.6-r3
new file mode 100644
index 000000000000..a54fd4aab988
--- /dev/null
+++ b/media-libs/libao/files/digest-libao-0.8.6-r3
@@ -0,0 +1,6 @@
+MD5 12e136a4c0995068ff134997c84421ed libao-0.8.6.tar.gz 387583
+RMD160 650258240295f221e95d39cf2380ada73f3cb4e1 libao-0.8.6.tar.gz 387583
+SHA256 99565c6f8a560abc24bf6c07726737d54db64daae08c8708fc9e8f3aeb723985 libao-0.8.6.tar.gz 387583
+MD5 137aaeb0d92033c5d9c4d3ccc6658c86 libao-patches-4.tar.bz2 3049
+RMD160 b6e8cc8495009a593f49c8d67c26f2d2b09ce119 libao-patches-4.tar.bz2 3049
+SHA256 fd913474cefc07528e6e45b24d2e5198ebe6b5d9dc763f4aa03d2e1802dec1d8 libao-patches-4.tar.bz2 3049
diff --git a/media-libs/libao/libao-0.8.6-r3.ebuild b/media-libs/libao/libao-0.8.6-r3.ebuild
new file mode 100644
index 000000000000..9e327f3aaffe
--- /dev/null
+++ b/media-libs/libao/libao-0.8.6-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.6-r3.ebuild,v 1.1 2006/10/02 04:05:52 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit libtool eutils autotools
+
+PATCHLEVEL="4"
+
+DESCRIPTION="the audio output library"
+HOMEPAGE="http://www.xiph.org/ao/"
+SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz
+ mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="alsa arts esd nas mmap pulseaudio doc"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.22 )
+ nas? ( media-libs/nas )"
+PDEPEND="pulseaudio? ( media-plugins/libao-pulse )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+
+ AT_M4DIR="${WORKDIR}/patches/m4" eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ # this is called alsa09 even if it is alsa 1.0
+ econf \
+ $(use_enable alsa alsa09) \
+ $(use_enable mmap alsa09-mmap) \
+ $(use_enable arts) \
+ $(use_enable esd) \
+ $(use_enable nas) \
+ --enable-shared \
+ --enable-static \
+ || die
+
+ emake || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}/usr/share/doc"
+ dodoc AUTHORS CHANGES README TODO
+ use doc && dohtml -A c doc/*.html
+}